Remote Desktop Connection not using saved credentials

Even though I've clicked "edit" and put in my credentials Windows 7 Remote Desktop Connection does not automatically use them.
The checkbox "always ask for credentials" is NOT checked.
When I connect from other Windows clients to the same target machine their saved credentials are used properly.
Is this a Windows 7 Remote Desktop Connection bug or am i doing something wrong?
 
Question Info

Last updated August 11, 2018 Views 125,821 Applies to:
Answer

When trying to use saved credentials in Remote Desktop Connection you might receive this message:

Your credentials did not work. Your system administrator does not allow the use of saved credentials to log on to the remote computer terminal.server.com because its identity is not fully verified. Please enter new credentials.

To be able to use saved credentials in this situation you need to do the following:

1. Open Group Policy Editor via cmd -> gpedit.msc

2. Navigate to Local Computer Policy\Computer Configuration\Administrative Templates\System\Credentials Delegation\
3.Open Setting Allow Delegating Saved Credentials with NTLM-only Server Authentication, set it to Enabled click on button Show... and in Show Contents window add Value TERMSRV/* Close all windows by pressing OK.

4. Run cmd and enter gpupdate command to update your policy.


Now you should be able to use your saved credentials.

127 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.