How to set inheritance on new external hard drive?

I have a new external hard drive from LaCie and I have placed all my images on it for use with Lightroom and Photoshop.

But, I can't save or save as in Photoshop and was told that the problem is because the permissions are not correctly set for the external drive. I looked at the permissions and it says "not inherited." I was told that the settings should be inherited.

How do I change this so the setting for Windows 7 are used by the hard drive? I plan to use this hard drive on both my desktop and laptop, so it needs to the two computers into account.

I've look at security settings for teh drive, but I don't understand them and so I don't want to change them.

 

Question Info


Last updated March 19, 2018 Views 939 Applies to:
Answer
Answer

I am a relatively advanced user. I'm sure that I can do teh changes myself, if given the steps. I found these steps given on a MS forum. Will these work? 
"Your external drive is formatted with the NTFS file system, which supports access restrictions.

Unfortunately, while some users and security groups are built-in to Windows with predefined Security IDs which are the same on all machines (such as Everyone), other users and groups have SIDs derived from the machine they're defined on.

To normalize the situation you should:

1.While logged-in as Administrator, right-click the drive's root directory and select Properties.
2.Click the Security tab, then the Advanced button.
3.In the Advanced Security Settings dialog for the drive, click the Owner tab, then the Edit button.
4.Click the Administrators group, check "Replace owner on subcontainers and objects", and click OK. If asked about replacing existing permissions with ones giving you Full Control, click Yes.
5.Back in the Security tab on the original Properties sheet again, click the Edit button, and in the Security dialog click Remove for all entries in the "Group or user names" except the well-known ones of System, Administrators, Users and Authenticated Users.
6.Click Add, and in the "Select Users, Computer or Groups" dialog Under "Enter the object names to select", type Everyone and click OK. You should see that Everyone has been added to the list.
7.Click Everyone, check Full Control, then click on Apply.
8.Click Advanced again to go back to the Advanced Security Settings dialog box. Check "Replace permission entries on all child objects" and click OK.
9.Click OK.
Be careful in the future not to allocate separate access permissions to sub-folders of the drive (leaving all permissions as inherited). If this happens again, repeat the step for "Replace permission entries on all child objects".

Be mindful of the fact that under Windows 7 the Guest account is not part of the Everyone group. If you need it, you'll have to add Guest as above for the Everyone group."


 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.