Error 5: Access Denied: Setup unable to create the directory ...

I am trying to install a program "Advanced System Care" I get a error message, Setup was unable to create the directory "C:\users\arthur\appdata\local\temp\is-rukl.temp  

error 5 Access denied

I realized today I believe I have gotten this error on several things I have tried to install recently.  I thought it was a problem with the actual program installer.

I have no idea where to even start.  Thank you for any help you can give me



This 8-year-old thread has long since run its course and is now locked.

If the marked Answer doesn't help you, please read the following articles and ask your own new question including details about your system and your specific problem.  Please ask your question in the section of Microsoft Community appropriate for your version of Windows.

How to begin your own, new thread about your computer & your problem
How to ask a question

If you're getting a problem trying to install Advanced System Care (as in the original question from July 2010), note than some antivirus/antimalware programs consider Advanced System Care to be a "potentially unwanted program" and may not let you install it.  See, e.g., the 20 Sept. 2014 post from mrphster on page 2 of this exceedingly long thread.  Also see



Question Info

Last updated July 15, 2019 Views 175,023 Applies to:

The problem is with the security permissions on your profile temp folder. To fix it navigate to %temp% or C:\Users\[Username]\AppData\Local and right click on the Temp folder and choose properties, then click the security tab and click advanced.

On the permissions tab you should see the permissions that are there. There should 3 which are:

'SYSTEM' with Full control which applies to 'This folder, subfolders and files'

'Administrators' with Full control which applies to 'This folder, subfolders and files'

'Your Username' with Full control which applies to 'This folder, subfolders and files'

and all 3 should be inherited from the C:\Users\[Username]\ folder.

If you don't have the 'Include inheritable permissions from this object's parent' option ticked, then tick it and click continue if there are any problems, then remove the permissions that aren't inherited.

Once you click 'Apply' and click 'OK' you should have the permissions to write to the directory and you won't get those error messages any more.

Hope this solves your problem

427 people were helped by this reply


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.