Cannot start Windows firewall service error windows could not start windows firewall on local computer error code 5.

Original title : How to fix corrupt Windows Firewall

 

A few days a go I ran Malwarebytes and it found and disposed of several infections.


But I thought it was strange that these had went unnoticed by my Microsoft Security Essentials and got through my Firewall. So to be sure nothing was left I ran MSE and went to check my Firewall. MSE was turned off and with a few attempts I got it running again and did another scan. Then I went to my Firewall and found this:


I click on the 'Use Recommended Settings' button but it doesn't do anything.

So I googled the problem and found some solutions (unfortunately not for me)
I tried to start the Firewall service and I got this error:


I downloaded and placed the registry keys for the Base Filtering Engine and Windows Firewall into the registry but that did not help.
The BFE worked fine but the Firewall service still wouldn't start. Also Windows Defender was disabled, but was fixed I believe after using the 'wscsvc' registry key.

I ran a disk check and used some commands (I believe 'netsh advfirewall firewall' and 'sfc')

Still no luck.

I then tried to use the Microsoft Fixit Tool but then I got this error:



I've been searching for a way to reinstall the firewall but haven't come up with anything. I don't want to use a third-party program, I want to continue using Windows Firewall.

Thank you in advance for your help.



 

Question Info


Last updated September 15, 2018 Views 108,481 Applies to:
Answer
I've already stated in my first post that I cannot run any  Microsoft Fix it tools, I am presented with an error.

The firewall service is already set to automatic and it won't start. I get an error (also shown in my first post)

Checking the Event Viewer I find that an Error with the WMI:

The Windows Security Center Service was unable to establish event queries with WMI to monitor third party AntiVirus, AntiSpyware and Firewall.

Also an Error with SDWinSec.exe:

The description for Event ID 0 from source SDWinSec.exe cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event: 

The service process could not connect to the service controller

ACPI: 

The embedded controller (EC) did not respond within the specified timeout period. This may indicate that there is an error in the EC hardware or firmware or that the BIOS is accessing the EC incorrectly. You should check with your computer manufacturer for an upgraded BIOS. In some situations, this error may cause the computer to function incorrectly.

Application Error:

Faulting application name: svchost.exe_HPSLPSVC, version: 6.1.7600.16385, time stamp: 0x4a5bc100
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x00610072
Faulting process id: 0x844
Faulting application start time: 0x01cd4a0aa52070a3
Faulting application path: C:\Windows\system32\svchost.exe
Faulting module path: unknown
Report Id: 6478f980-b65b-11e1-bdf1-002219ec7c84

Microsoft Antimalware:

Microsoft Antimalware has encountered an error trying to load signatures and will attempt reverting back to a known-good set of signatures.
  Signatures Attempted: Current
  Error Code: 0x80070002
  Error description: The system cannot find the file specified. 
  Signature version: 1.127.2001.0;1.127.2001.0
  Engine version: 1.1.8403.0

Disk:
The driver detected a controller error on \Device\Harddisk1\DR1.

ApplicationExperienceInfrastructure:

The application (Microsoft SQL Server 2008, from vendor Microsoft) has the following problem: After SQL Server Setup completes, you must apply SQL Server 2008 Service Pack 1 (SP1) or a later service pack before you run SQL Server 2008 on this version of Windows.

I tried to install Visual Studios earlier today but I got another error:

KB2581206 does not apply, or is blocked by another condition on your computer. Please see http://go.microsoft.com/fwlink/?LinkId=225649 for more details.

iBecause I thought there was a problem with the WMI.  A few searches later I found a forum that told me to add the following command into the command prompt:

 mofcomp "C:\Program Files (x86)\Microsoft SQL Server\100\Shared\sqlmgmproviderxpsp2up.mof"

But I got another error:

Microsoft (R) MOF Compiler Version 6.1.7600.16385
Copyright (c) Microsoft Corp. 1997-2006. All rights reserved.
File 'C:\Progam Files (x86)\Microsoft SQL Sever\100\Shared\sqlmgmproviderxpsp2up.mof' not found!

And if I try to look in the directory I don't have a Microsoft SQL Server folder.

Cannot start Windows firewall service error windows could not start windows firewall on local computer error code 5.
Solution
  1. In Registry Editor, browse to the key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess
  2. Right click SharedAccess, and click Permissions.
  3. Click Add.
  4. In the “Enter the object names to select” field, type “NT SERVICE\mpssvc”. Then click Check Names. The name should change to MpsSvc
  5. Click OK.
  6. Select Full Control in the Allow column.
  7. Click OK.
Applies To

Windows 7 (all versions) / Windows Vista (all versions)

84 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer

Hi,

I would suggest you to perform inplace upgrade or reinstall Windows 7, since you have tried all the steps to resolve the issue. Follow the steps in the link:

“How to Perform an In-Place Upgrade on Windows Vista, Windows 7, Windows Server 2008 & Windows Server 2008 R2”

http://support.microsoft.com/kb/2255099

“Install, reinstall, or uninstall Windows”

http://windows.microsoft.com/en-us/windows/help/install-reinstall-uninstall

Before performing inplace upgrade or reinstall Windows 7, you may backup the data. Follow the steps in the link:

“Back up your files”

http://windows.microsoft.com/en-us/windows7/back-up-your-files

“Back up your programs, system settings, and files”

http://windows.microsoft.com/en-us/windows7/Back-up-your-programs-system-settings-and-files

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.