Cannot start Windows 7 Firewall. Get Error 08x007042c.

Cannot start Windows 7 Firewall. Get Error 08x007042c.

More information I have found on the the problem. 

The error log indicates: The Windows Firewall service depends on the Base Filtering Engine service which failed to start because of the following error:
Access is denied Event ID 7001.

The error logs indicate the Base Filtering Engine service terminated with the following error:
Access is denied Event ID 7023.

Also I checked the dependent services Remote Procedure Call (RPC), DCOM Service Process Launcher and RPC Endpoint Mapper are both started. 

 

Question Info


Last updated January 24, 2019 Views 165,978 Applies to:
Answer
Hey! If you have this crappy problem just do this: run-services.msc-base filtering engine: double click-make sure u have the local service, and empty password under LOGIN button. do the same on windows firewall in services. then go to regedit http://support.microsoft.com/kb/943996/en-us do that AND!!!! give another user to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services user must be called: NT Service\bfe with full control! Then you can start bfe, and then you can start that firewall in services.msc! cheers!

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer

Resolved this on Windows 2008 x64 using the above mentioned guide by abellos and the following:

Trying to start the "Base Filtering Engine" resulted in more Access is Denied errors.
 
Using SysInternals ProcMon.exe I discovered that HKLM\System\CurrentControlSet\Services\BFE\Parameters\Policy\Persistent and HKLM\System\CurrentControlSet\Services\BFE\Parameters\Policy\BootTime\Filter where the cause of the Access Denied messages.
 
Strange thing is that the NT AUTHORITY\System is given Full Access to both entries. adding the "NT Service\MpsSvc" group with Full Control seems to provide a fix for me.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.