Access denied to DVD Drive

I put in a new DVD drive, firstly it was not recognised but I deleted the upper and lower filters in the registry and that worked. It seemed to be ok but had an error reading a disc and then it was not recognised again - now it is there but access is denied. When I go to windows explorer it doesnt show its there but it does if I click computer - when I right click it and go to security unless I put a disc in it says the device is not ready. When I click on the ok in the security tab it says the requested security info is either unavailable or cannot be displayed. When I go to the advanced tab I can try to put in info but it wont save anything as access is denied..... I logged onto my administrators account and the drive is there and accepts dvd's/cds although there seemed to be errors in actually getting anything to play.
I have tried system restore but that came up with an error sfi.dat missing so didnt make any changes either... I have tried uninstalling the device, thats ok and it reinstalls when I reboot but nothing has changed and access is denied.
Is there anyway to delete the current info for it from the computer and start fresh? Is nero or other software likely to be causing this?
Any ideas please!!
Running windows 7 home
Thanks
Rebecca
 

Question Info


Last updated September 25, 2018 Views 53,993 Applies to:
Answer

I had to open disk management, right click on the CD/DVD drive and open Properties, click on the Hardware tab, click the properties command button, click on the driver tab, and uninstall the driver.

Then click on the Disk Management Action menu, click on Rescan Disks, it re-adds the drive and the error is gone!!

108 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.