WMP doesn't detect my device

My computer does detect my Smartphone, connected with USB cable, but WMP doesn't.

When I plug it with USB cable, WMP says: "Connect a device" but it is already connected because the computer has installed the drivers needed and mounted 2 disks: F:\ and K:\.

Therefore, I can see these 2 drives and the files inside and I can copy music, videos, etc... but I cannot sync music with WMP.

 

I have checked in other XP and W7 computers and it worked: My device was detected and syncing started. However this doesn't happen in my W7 computer where I have all my music Library and Playlists.

 

I must admit that syncing worked in my W7 computer until aprox. 2 months ago. Changes since then are: Installation of new version of Norton Internet Security and probably updates on W7 with automatic Windows Update.

There has been a remarkable change on my phone: As I wanted to use an external SD card to increase MB used for music, I deleted all my music and playlists. Afterwards, when trying to sync everything again with my new external SD card WMP said: Device is not connected :-(

 

WMP used is version 12.0.7601.17514 on W7 Home Premium

 

Your help will be welcome.

Jesus

 

Question Info


Last updated February 8, 2019 Views 599 Applies to:
Answer
Hi Sengupta,
Thanks for your reply.
I disabled Norton Internet Security with no sucess.

However I saw in another Windows Community thread a solution that works for me too.
Was the reply given by Murph570.
http://answers.microsoft.com/en-us/windows/forum/windows_vista-pictures/windows-media-player-doesnt-recognize-mp3-player/65fab396-4ba0-44f2-b3a5-7136b1ceb590.

The solution was to delete c:\User\"my login"\AppData\Local\Microsoft\Media Player and let WMP to rebuild it again.

Thanks anyway for your help

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.