WMC and Media player don't play when started with HDMI audio enabled

This is an update of a previous post in October (WMC-Live CODEC error on recorded TV...).   I have finally managed to get WMC and Media player to work via HDMI and with audio, but through a method that I can only conclude points to a bug in those applications, or the OS.   When WMC or media player is started while a TV is connected via HDMI, AND, the HDMI audio driver is selected by default, playing any recorded TV files halts the player immediately on play start with an error message.  When either application is started with HDMI connected but audio default set to the speakers of the laptop, the TV files will play but the sound comes out of the laptop speakers.  I could patch the laptop headphone jack to the TV audio system, but this is rather inelegant; HDMI audio should just work.

Now the interesting part; after starting a file in WMC or Media player with the laptop audio selected, I paused the playback, then went into control panel and changed the audio default from the laptop speaker to the HDMI digital (NVIDIA driver for this laptop).  I was expecting the player to halt with the error as soon as I took the playing file out of pause, or at least resume without any sound at all, but was surprised when the playback resumed normally, and the audio was now coming from the TV through HDMI, the way the applications should work.  This is pretty clear proof that there is no hardware or driver issue here.   As I pointed out in the original post, VLC player works fine with HDMI default enabled, further pointing to some sort of bug in WMC and Media player.
Answer
Answer
OK, I think I just stumbled onto the solution to this problem.   It took some searching through the (MS hosted) Windows Experts forum on WMC, but a solution that worked for a slightly different problem turned out to also solve the problem I was having.

So what was it?  follow these steps:

Go into Control Panel, find and open "Manage Audio Devices"

With the HDMI TV connected and active, select the (NVIDIA) HDMI Digital Audio Device and open up the Properties

Select the Advanced tab

In the Exclusive Mode box, uncheck the tickbox titled "Allow applications to take exclusive control of this device"

That's it.  Everything now works as it should with WMC and Media Player both playing TV files correctly with the HDMI audio enabled.

I don't know what the consequences of having that box unchecked will be, but clearly, the default setting when the OS was upgraded and the driver loaded had that checkbox enabled.  If an auto-update changes this setting back to default, this could explain how something that was working, suddenly and mysteriously stops working.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated January 31, 2019 Views 1,749 Applies to: