Windows media player 'class not registered' annoying!!!!

Whenever I try to open a file with windows media player it always says 'class not registered' I've tried everything, including downloading media player fix it software and installing codecs but nothing works. Please help me!
Hi

Open an Elevated Command Prompt, using right click --> Run as Administrator, now type:
regsvr32 quartz.dll

Now press enter, you should get a pop up say the Dllregisteration has succeeded.
Please try opening a file using Windows Media Player does it still error?

165 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

it didn't work unfortunately..thank you anyways.

Any other solutions? I'm using windows 7.
I tried every registry cleaner under the sun and nothing..

Any other ideas would be most welcome. 

Thanks!

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Does it just say Class not register?

5 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

yes it says c:users/(filename) and then underneath that says class not registered. Please there must be some other solution, I can't be the only one the above solution does not work for. Microsoft sucks **** seriously

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Salvador,

 

Have you made any changes to your computer prior to the issue?

 

I would suggest you to follow the steps and check if it helps.

 

 

Method 1: Run Windows Media Player settings troubleshooter and check if it helps.

Open the Windows Media Player Settings troubleshooter

 

Method 2: Re-register files related to Windows Media Player. To do this, follow the steps below.

a. Click on start and in the start search bar type cmd, right click on the command prompt icon in the programs area and then click on run as administrator.

b. At the command prompt

          i.            Type regsvr32 wmp.dll and then press enter.

         ii.            Type regsvr32 jscript.dll and then press enter

        iii.            Type regsvr32 vbscript.dll and then press enter

c. Restart the computer and then check if the issue is resolved.

 

Method 3: Disable and enable Windows Media Player from Windows Features and check if it helps.

a)      Go to Start.

b)      Type Turn Windows features on or off and open it.

c)       Uncheck Windows Media Player under Media Features and click OK.

d)      Restart your computer.

e)      Open Windows Features on or off.

f)       Enable Windows Media Player under Media Features and click OK.

g)      Restart your computer

Turn Windows features on or off

 

 

 

18 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I did the troubleshooting and is says 'issues found - configuration settings might be set incorrectly. Detected and exclamation mark.'

What does that mean?

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Salvador,

 

This indicates that there where some issues in the settings, this may happen due to the installation incompatible Codec's. Post back the updated status of the issue to help you better.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Very Very helpful

thank you

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Very Very helpful

thank you

I just have the same problem, I am not clear with the solution.

Please direct me to it.

Thanks,

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated September 21, 2020 Views 11,771 Applies to: