Windows Media 12 Player Error: Interface not registered

Whenever I double-click on an MP3 or WMV file to play in Windows Media Player 12, I get a notification that says "Interface not registered." It was working fine the other day! However, I can still play all my audio files that are currently in my Media library or open files via File>Open in the player menu -- this message comes up if I double-click on the file itself. If I open audio files via iTunes, RealPlayer, and QuickTime, they will play, but WMP is my preferred playback program.

I have tried running my anti-virus/anti-spyware/anti-malware programs, System Restore, unchecking and rechecking Media Player in Auto Features in the Control Panel (with restarts as needed in between), as well as running the SFC scan (which didn't give me any results, but rather just closed itself out after it reached 100% validation). 

I cleared out the .wmdb files in Local Settings/Media Player, and that allowed the player to automatically add new files to the library, but I still cannot double-click on an MP3 or WMV file in a folder to open it in the player. 

What else could I try? I see where downloads of WMP12 are not available from Microsoft (due to it being pre-installed on Windows 7), and do not feel comfortable downloading it anywhere else. Help is greatly appreciated! Thank you!

Addition - I recently tried to burn music to a cd, and that worked like normal, so not sure what the problem would be?
 

Question Info


Last updated March 15, 2018 Views 1,305 Applies to:
Answer

Hi amcjacob,

Method 1
I would suggest you to perform SFC scan so that if there is any system files corrupted will get replaced.

How to use the System File Checker tool to troubleshoot missing or corrupted system files on Windows Vista or on Windows 7
http://support.microsoft.com/kb/929833

Method 2

Disable and Enable Windows Media Player:

Step 1: Uninstalling the Windows Media Player:
1. Go to Start and in the search type "Turn Windows features On or Off".
2. Click on "Turn Windows features On or Off".
3. Browse to the Media Features and uncheck the mark in front of Windows Media Player.
4. Restart the computer
 
Step 2: Reinstalling the Windows Media Player:
1. Go to Start and in the search type "Turn Windows features On or Off".
2. Click on "Turn Windows features On or Off".
3. Browse to the Media Features and place a check mark in front of Windows Media Player.
4. Restart the Computer.


Turn Windows features on or off
http://windows.microsoft.com/en-US/windows7/Turn-Windows-features-on-or-off

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.