Windows Explorer no longer shows video previews in Windows 7

I run a 64 bit version of Windows 7 Home Premium. I know that it used to show a preview of all videos in the thumbnail, but now for some reason I only get the file type icon in the Windows Explorer view. Even when I select the file, there is no preview in the detail bar at the bottom. I only get previews for .mov and .mp4, but I no longer get them for .flv, .avi, or .wmv.

Question Info

Last updated June 15, 2019 Views 16,261 Applies to:

Step 1: We suggest that you cross check if the option "Show thumbnails instead of icons" is selected on the computer.
a. Click Start, click Control Panel. (Classic View)
b. Click on the System icon.
c. Click on the advanced system settings link.
d. Under Performance, click on the Settings button.
e. In the Visual Effects tab, Check "Show thumbnails instead of icons"
f. Apply the changes, restart the computer and check if the issue persists.
Step 2: This problem also occurs because Windows may not update the thumbnail cache.
To resolve this problem, reset the thumbnail cache. To do this, follow these steps:
a. Click Start, click All Programs, click Accessories, click System Tools, and then click Disk Cleanup.
b. If you are prompted, click My files only.
c. In the Files to delete list, click to select Thumbnails.
Note: Configure other options that you want.
d. Click OK, and then click Delete files.
e. Restart the computer and check the result.
Step 3: If the issue persists, run sfc (system file checker) scan to scan and fix missing or corrupt system files
NOTE: Sometimes non Microsoft media players may cause this issue. Disable them and check the result. Performing clean boot is like disabling non Microsoft programs.
Syed - Microsoft Support.
Visit our Microsoft Answers Feedback Forum and let us know what you think.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.