The problem 'Your current security settings do not allow this action' when I want to open swf file in Windows Media Player.

         How to solve the problem when I want to open the swf file in windows media player? Half year ago, when I click a swf file, it could auto play in Windows Media Player.

         Now when I want to open a swf file with Windows Media Player, it pops up a window  "Your current security settings do not allow this action". 

         How do I use watch the swf video in Windows Media Player?

 

 

 

 

 

Question Info


Last updated November 17, 2018 Views 49,468 Applies to:
Answer

When trying to play your local .swf files in the Windows Media Player, you will probably be met with a message saying that your Internet Explorer security settings do not allow this file type (ActiveX Control) to be opened. This stems from the fact that Windows Media Player uses as its own security settings the Internet Explorer Security. Therefore, these .swf files will play quite happily within Internet Explorer; the reason being that Protected Mode is OFF when a local disk file is opened. But Windows Media Player makes no such concessions, all ActiveX controls are forbidden.

The problem arises in the Local Machine Zone Lockdown feature. Windows Media Player needs to load the Flash Player control to play the SWF file. But this Lockdown prevents the automatic loading of the Flash Player control (remember, all controls are deemed unsafe in WMP)!

However, don't despair. This issue can be easily resolved by a simple modification to the Registry. There are two ways you could do this - pick the one that you feel more comfortable with.


Method 1 - Automatic Registry Change (Use this if you have never used the Registry Editor before):
-------------------------------------------------------------------------------------------------

Open a new Notepad document. Copy and Paste the following two lines of text to the blank document...

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Lockdown_Zones\0]
"1200"=dword:00000000

Save the document as "wmp_swf.reg" (the .reg extension defines the file as a Registration Entry). Save it to a location of your choice. This could be the Desktop or your Documents folder. Close the Notepad window.

Now locate the file at the location where you just saved it. Right-click on the file and choose "Merge" from the menu. Windows may ask for permission to continue, so click "Continue" or "OK". That's it! Windows Media Player will now play all your local .swf files without complaint.


Method 2 - Manual Registry Change (For the more experienced Registry Editor user):
----------------------------------------------------------------------------------

Open the Registry Editor (ie Run "regedit.exe" and give Windows permission to continue).

Navigate your way to the following folder...

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Lockdown_Zones\0

In this folder "0" (zero), locate the entry "1200 REG_DWORD 0x00000003 (3)" in the viewing pane.

Right-click on the "1200" and choose "Modify..". Change the highlighted value of "3" to "0". Press OK. The entry will now show as "1200 REG_DWORD 0x00000000 (0)". Close the Registry Editor.

This simple procedure now allows Windows Media Player to play local .swf files.


Now you've completed this fix, it might be a good idea to change the default opening program for your .swf files to Windows Media Player. I find it more convenient than playing them through Internet Explorer.

73 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer

Hi,

SWF is a file format for multimedia, vector graphics and Action Script in the Adobe Flash environment. Originating with Future Wave Software, then transferred to Macromedia, and then coming under the control of Adobe, SWF files can contain animations or applets of varying degrees of interactivity and function.

 

SWF functions as the dominant format for displaying "animated" vector graphics on the Web. It may also be used for programs, commonly browser games, using ActionScript.

 

Method 1:

 

I would suggest you to open he file in Internet Explorer and check if you face the same issue.

 

Method 2:

 

Step 1:

You can also try to reinstall Flash Player on the system to resolve the issue.

 

To uninstall a program in Windows 7 refer to the link provided below

http://windows.microsoft.com/en-IN/windows7/Uninstall-or-change-a-program

 

Step 2:

 

Once you uninstall the Flash Player reinstall it back and check if you face the same issue.
To download the latest version of Flash player refer to the link provided below

http://get.adobe.com/flashplayer/

 

Once you download Flash Player refer to the link provided below to install a downloaded program in Windows 7.

http://windows.microsoft.com/en-US/windows7/Install-a-program

 

 

 

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.