Netflix in Media Player error: "We could not load the movie player"

I recently installed the Netflix add-on to my Windows Media Player.  It was working fine (although I don't find Windows Media Player to be a very good product) but now when I try to play something from Netflix I get an two error readings - one on top of the other.

  • The first error reading is:  "We could not load the movie player"
  • The other on another pop-up window begins with:  An error has occurred in the script on this page."  There are then several lines with specifics and a URL and then it asks:  "Do you want to continue running scripts on this page?"  With the Yes or No option buttons.

I have tried to uninstall the Netflix add-on and reinstalling - but that does not change anything.


I thought about uninstalling Windows Media Player and reinstalling - but I can't even figure out how to do that.


Any suggestions.


Thanks -


Alonzo


 

Question Info


Last updated September 23, 2018 Views 1,016 Applies to:
Answer
Hi -

Your suggestion worked - but not the first time.

What I did do was to uninstall both the Netflix add-in and Silverlight.  Then I reinstalled Silverlight and then Netflix and it worked.

Thanks for your assistance.  It did work.

Alonzo

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Download and install latest version of Silverlight.


Windows Entertainment and Connected Home MVP
http://mymce.wordpress.com/

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.