Media Sharing not working with Windows 7 (devices can 'see' library and music, but cannot 'play' the songs)

I recently upgraded my Vista machine to Windows 7 Home Premium.  I am now trying to set up my Roku and other PCs to be able to use my media library.  Since my other PCs are not Windows 7, I have not formed a homegroup.  From the Windows 7 machine, everything appears to be OK.  I can see the various devices, and assign the appropriate permissions.  However, from the Roku and other PC, they are not able to play the music.  What is strange is that they can 'see' the music and the library, however, they are not able to actually play the music. 

Does anyone have any suggestions?

Thanks!
 

Question Info


Last updated March 16, 2018 Views 5,914 Applies to:
Answer

Hi R.Neher,

Welcome to Microsoft Answers.

You may try these:

Allow all current and future devices on your network to access your media library. Here's how:

1. Click the Start button, click All Programs, and then click Windows Media Player. If the Player is currently open and you’re in Now Playing mode, click the Switch to Library button in the upper-right corner of the Player.
2. Click Stream, and then select Automatically allow devices to play my media.
3. In the Allow All Media Devices dialog box, click Automatically allow all computers and media devices. If you don't want to allow access to all devices, click Do not automatically allow computers and media devices.

Note: You should only allow streaming access to all devices on secure networks.

Check the link “Change settings for streaming media in Windows Media Player” http://windows.microsoft.com/en-US/windows7/Change-settings-for-streaming-media-in-Windows-Media-Player

Refer to the link "Stream your media to devices and computers using Windows Media Player"  http://windows.microsoft.com/en-us/windows7/Stream-your-media-to-devices-and-computers-using-Windows-Media-Player

Diana
Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us know what you think.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.