Media Player 12 does not recognize removable media (drive letters, sd cards, compact flash, usb drives, android phones) as a syncable device. Running 7 64 bit.

Tried and tried to get this to work. According to Microsoft advertisements you can sync to removable media however whenever I try to get Media Player 12 to sync it searches for devices and comes up empty. I have the devices plugged in and they have drive letters in Windows Explorer. I've even clicked on the "open as a portable device" link within Windows Explorer and then went back to media player and it doesn't see it. I can open whatever music is on the device from the file menu in media player. In mp 11 I could sync all day long with my removable devices. I just thought they had disabled this functionality until I read that you are actually supposed to be able to do it. I've connected my Samsung Captivate as Mass Storage and tried as well, but obviously failed. I've connected it as an MTP device and within Windows Explorer one of the Autoplay options is to "Sync digital media files to this device using Windows Media Player". So thinking this will for sure work, I try it many times, rebooting computer and phone. Recognized again in Windows Explorer, everything seems as it should be no driver problems, but still Media Player does not recognize my device! HELP!!!

Update: I left a removeable usb stick in connect for three and a half hours. Forgot about it with media player running, came back and noticed it was listed as a device in media player. So you would think you could sync to it right? WRONG! I dragged some music to sync to it and the sync button was greyed out. Plenty of space on the device. Thought well, MP now recognizes the drive, I'll unplug it and and plug it back in and maybe that will fix whatever glitch MP is experiencing. Wrong again! Again MP doesn't find the device! I thought Software/Computers were supposed to get faster not take 3.5 hours to connect a device and then maybe someday in the future you can sync your device. But at this point still no luck. I had just thought that Microsoft decided to get rid of the functionality within MP to sync to removable devices because I could never get this far until reading last night that it is supposed to work with usb drives, sd cards and removable media. After having no luck in getting MP to reconnect to my usb stick I cleared the device cache thinking that would help, but no it did not.

Another Update: When I connect my phone as an MTP device, the AutoPlay comes up and there is an option to sync with Windows Media Player. When I click that option, MP opens and then says: "searching for devices" and never finds the "SGH-I897" (Samsung Captivate). Either way whether I mount as Mass Storage or as the MTP device Windows sees it and I can move files, but cannot get Media Player to find it or recognize it! It should be simple enough that if Windows finds it, Media Player should find it.

 

Question Info


Last updated December 10, 2018 Views 7,690 Applies to:
Answer
I'm pretty sure that WMP can only sync to removable drives. Because the Cruzer 32GB reports itself as being a local disk, WMP doesn't list it as a device to sync to.

Unfortunately, it appears that SanDisk has done this intentionally without providing any workaround:

http://kb.sandisk.com/app/answers/detail/a_id/12830/~/flash-drive-shows-as-hard-disk-drive-
Tim De Baets
http://www.bm-productions.tk

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.