I cant View My Pictures on Windows 7!?

I just installed windows 7 on my computer and ALL my files are still on the computer you can see all the thumbnails. But when I click the picture to open it I get this message "Windows photo viewer can't open this picture beacuse you don't have the correct permissions to access the file location" YET Im the administrator and everything?? Please help me!
 
Question Info

Last updated August 16, 2018 Views 31,701 Applies to:
Answer
Hi,

I Searched the net and tried all the 'ownership' answer/resolutions i could find. However none of these worked.
Turned out the problem lay within the original directory i had put the photo's into.
I had uploaded my memory card in one of my other 'user' accounts and locked it by puting there 'share' with 'nobody'. Even though as the administrator and the 'owner' of the orignal pictures i could not access them on my own 'user account as administrator'.

The way i personally solved the issue was to log into the other user account. 

Click the Hard Drive
Click Users
Click My Account eg c:\users\carley\my pictures\folder
Right click 'Folder' 
Scroll down to 'Share With' click 'Specific People'
Remove all names except your own who should be labelled 'Owner'
Click 'Share' and 'Done'

Once this is done click 'Folder' once more
Scroll down to 'Share With' BUT this time click 'Nobody'

Also check within the properties of this folder whether the 'read only' box has been checked if so 'uncheck'

Log out of this user and Log back in as the 'Administrator'

Access the same folder check the settings you made are the same for the other account you have just been in then wait a few minutes and the lock on the pictures should disappear and all your pics should then be displayed.

This worked for me i hope it works for you <3

11 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer

Hi,
Welcome to Microsoft answers.

Open up Windows Explorer.Find any file with that same extension, and follow the steps:
 
1. Right-click on the filename, and select Open With 
Select Choose Program at the bottom of the list that's displayed.
2. In the resulting dialog box, "Windows photo viewer " should already be listed. Click on it.
3. Check the box labeled "Always use the selected program to open this kind of file".
4. Press OK

Now try opening the pictures.
 
I also suggest you to give full permission, follow these steps:
 
1. Right click on the the folder.
2. Goto properties, and click on security.
3. Under groups or User names, select Everyone.
4. Under permission for everyone, select full control.
5. Apply and then ok

For more information, logon to:
http://social.answers.microsoft.com/Forums/en-US/vistafiles/thread/465f2b42-63dd-4486-8dd1-c870290efeed


Let us know if you have any issues.
 
Thanks and Regards,
Azam - Microsoft Support.
 

11 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.