How to disable the "Windows Media Player cannot download media information..." pop-up after ripping a CD without enabling network connectivity.

When I rip a CD using Windows Media Player, I get the following pop-up message after the rip is complete: "Windows Media Player cannot download media information for this CD. The tracks, artist, and album will be identified as "Unknown" in your library. For best results, connect to the Internet or manually add media information for the CD."

I know that the message does not pop up when I enable setting to allow WMP to connect to the internet to get media information, but I don't want WMP doing that. What I want is a button I can push on the pop-up that says "Never show this message again" (similar to the warnings seen in internet explorer). How can I disable this pop-up without turning on the internet connection option.

In case you are wondering, the data from the internet is inconsistent in naming convention so when I rip an audio book so I can listen to it on my mp3 player, I can not script the post processing completely because the not all discs in a set have consistent naming on the tracks or even the disc, etc. At least discs labeled as "Unknown" are consistent and thus easy to script for reduction to a single MP3 file.
 
Question Info

Last updated July 19, 2018 Views 2,877 Applies to:
Answer
Hi,

Perform the following steps and check if they help.

Registry disclaimer
Important: This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

How to back up and restore the registry in Windows
http://support.microsoft.com/kb/322756/

a. Start Windows Media Player. Right-click the toolbar at the top, select "Tools" and choose "Options."

b. Select the "Privacy" tab. Uncheck every option in the tab.

c. Select the "Network" tab. Uncheck all options within this tab as well. Click "OK."

d. Click "Start," choose "Run," and then type "regedit" in the field provided. Press "Enter." Click "File" and "Export." Type a registry backup file name that you can remember and that contains today's date. Navigate to the registry key "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\PlayerUpgrade." Under "Name," double-click "EnableAutoUpgrade." Under "ValueData," type "no." Navigate to "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft."

e. Click "Edit," "New" and "Key." Type "WindowsMediaPlayer." Click "OK." Select the new key and click "Edit," "New" and "DWORD Value." Type "DisableAutoUpdate" and press "Enter." Select "Edit" then "Modify." Type "1" and click "OK." Click "OK." Click "File" and "Exit" to close the registry editor.

f. Click "Start," "Control Panel" and "Security Center." Under "Manage Security Settings for," click "Windows Firewall." Click the "Exceptions" tab. Scroll down until you see "Windows Media Player." Ensure that the box beside the entry is unchecked. Click "OK."

g. Right-click the toolbar in Windows Media Player. Select "File" and "Work Offline" to completely prevent Windows Media Player from accessing the Internet in any way. When you want to restore Internet access, right-click the toolbar, click "File" and remove the check mark beside "Work Offline."

That should do it.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.