Configuration error setting up Xbox 360 as media extender with Windows 7 media PC

Currently running Windows 7 x32.

Until recent update to XBox 360, all was working fine using 360 as a media centre extender.

Now fails and when I try to resestablish a connection a configuration error arises.

Network connection seems fine as I can still stream media fine to Xbox dashboard.  Media centre seems to find and install extender OK, just fails at configuration.

Have tried with AV and fiewalls disabled (Karspersky) with no success. 

Frustrating as was working fine, now the functionaility is lost.

ANy help would be greatly appreciated

|
Answer
Answer

For months, I experienced a problem exactly like the one described here, but I've finally fixed it on my machine and I believe I've got to the core of it.

The fix (this is for Windows 7, may also apply to Vista):

1. Find your 'Users' folder (usually c:\users).

2. Under 'Users' folder, go to subdirectory 'Default\AppData\Local\Microsoft\Windows Live'.
Note: The directory may not exist, but I've seen the extender problem only on a computer that does have it.

3. Inside this directory, there are additional subdirectories (e.g. 'Bici' and 'SqmApi'). Inside, there are several files with .sqm extension. THE PROBLEM IS WITH .SQM FILE PERMISSIONS. Specifically, the profile service has no permission to access or copy the files when creating a new profile.

4. To fix the permission issue, perform the following actions on each of SQM files.
Note: Inheriting parent container permissions will grant Everyone read access to the files.

a. Right click on the file, select Properties.
b. Select Security tab, click on Advanced button
c. Select Permissions tab (selected by default), click on Change Permissions... button.
d. MARK THE CHECKBOX: Include inheritable permissions from this object's parent.
e. Press OK button several times to close all the dialogs.

Then, setup Media Center Extender per regular instructions.

While these steps successfully repaired my computer, they may not apply to every situation. My advice is to run the following diagnostics steps:

1. Use Control Panel to create a new user account.

2. Use 'Switch user' (or Log off/Log on) in an attempt to log into this new account. This attempt will fail (if not, you may have a different problem).

3. Examine 'Application' event log (under 'Windows Logs') for the relevant events.

On my machine, I've got several warnings with Event Id 1509 about the files that couldn't be copied from Users\Default to Users\TEMP due to access denied errors. These were .sqm files with incorrect permissions.

If you like this solution, you may also like our http://docs.com service ;-) The solution presented here can be found in a documenthttp://docs.com/AF1P.

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated June 18, 2021 Views 10,537 Applies to: