Clicking sounds when using USB headset microphone (Plantronics Audio 655)

Hi, as in the title I get a continuous clicking noise when I record from the USB microphone. It seems to be similar to the problems people were having with XP 64bit and Vista 64bit in these two threads:

 http://forums.logitech.com/t5/Headphones-Headsets-Microphones/G35-is-recording-clicking-sound/td-p/330021

http://forum.skype.com/index.php?showtopic=70211

At the bottom of the skype thread there is a link to a possible fix for Vista 64bit systems but there does not seem to be one for Windows 7 64bit.

edit: link: http://support.microsoft.com/kb/933433/ 

I'm fairly sure the problem does not reside with the headset as I have taken the first one back for a replacement thinking just that. I have tried different USB ports with no success.

Is there a fix out for this and is there any further information you may need to help me fix this?

I am running Windows 7 64bit , 4gb+ ram and onboard audio.

Cheers,

JakeQ 

 

Question Info


Last updated December 11, 2018 Views 8,997 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi JakeQ,

Which application you are using to record audio?

You may follow these steps & check if the issue persists.

a.Right click on the volume icon and click Playback devices.

b. You may select the device from the playback device list & click on properties.

c. Uncheck the option ‘Enable audio enhancement’.

Hope the information helps. Please post back and let us know.

Regards
Debleena S
Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us know what you think.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Debleena,

I am using Audacity to record but the clicking can also be heard using windows sound recorder.

I do not get any clicking during normal usage, it only occurs when I am attempting to record with the microphone.

Unfortunately the steps above have not solved the problem.

Is there anything else I can try or is this one where I would have to wait for an update from Microsoft? Looking around some other forums it seems this problem has been around since the RC stage of Windows 7.

Cheers,

JakeQ

 

Edit:

The clicking noise also occurs when I open Starcraft 2.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Debleena,

Is there anything else that can be done? I have the latest drivers, windows 7 is up to date. I have disabled various real time scanners (avast) but the problem still persists.

Cheers,

JakeQ

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello Jake,

In addition to Debleena's reply, please relay the make & model of your PC and if the device is connected directly to the PC or to a docking station.  Please also relay if the same issue occurs when the device is connected to another PC.

Also, you may try the below steps to help troubleshoot the issue:

·        Verify that the headset is set as the default recording device under  Sound>Recording Devices. Next, you may run the Recording Audio troubleshooter that checks the sound card and for a working recording device installed on your PC. To run the Recording Audio troubleshooter please see the link below:

 

Open the Recording Audio troubleshooter

 

·        If the issue persists, try lowering the Microphone level under  Sound>MicrophoneProperties. To do this, right click the Speaker icon in the Taskbar and select Recording Devices. Next, right click the recording device and select Properties>click the Levels tab and try lowering the microphone level and then check the issue. 

For additional assistance, you may also try contacting the device manufacturer directly by clicking the link below:

http://www.plantronics.com/north_america/en_US/support/;jsessionid=8CBF5D813B03759FF92073FD8EEEF226.charlie

I hope this information is helpful.

Thank you,


Mary
Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us know what you think.
Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Mary,

The headset is able to record sound but there is a persistent clicking noise in the background. The two troubleshooting measures above do not help at all. Lowering the recording level to 0 does make the clicking slightly less audible. The clicking/popping is also audible when watching videos and the microphone is muted.

My pc specs:

CPU: AMD AM3 550

Motherboard: Gigabyte M720 US3

GPU: Powercolor ATI 5750

Ram: DDR2 2GB 800 x2

HD: 500gb Seagate + 1tb Seagate SATA2 7200rpm

The headset is directly connected to the pc. Plugging it into different ports does not help. The issue is also present when connecting the headset to my laptop (Asus A8JP) running Windows 7 64bit. Both systems are fully updated.

The device manufacturers website did suggest that it may be an issue with DirectX hardware Acceleration being too high but there is no option to turn it down in Windows 7 (no more support for hardware accelerated audio from Vista onwards it seems).

http://soundingboard.plantronics.com/t5/Computer-Internet-Calling/Audio-655-pop-filter/td-p/4245

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello JakeQ,

Thank you for your reply.

You may verify that the latest chipset drivers that are Windows 7 compatible are installed for your motherboard and then check the issue. If the issue persists, you may also try deleting the driver software completely for the Plantronics Audio 655 device in Device Manager and then try reinstalling the device and check if it helps to resolve the issue.

To do this, right click the device in Device Manager and click Uninstall. Next, click Delete the driver software for this device and then click OK.

Next, you may try re-connecting the device and check if the issue persists.

If so, as the issue occurs on two different machines, then you may try contacting the device manufacturer to check for any available updates for the device.

I hope this helps.

Thank you,

 


Mary
Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us know what you think.
Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Mary,

All drivers are updated, motherboard drivers are windows 7 compatible. I have already tried deleting and reinstalling the driver for the headset with no success.

The device manufacturer offers no driver support whatsoever.

Update: Clicking sounds can be heard when playing videos and opening Starcraft 2. More help would be great.

Cheers,

JakeQ

 

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Quoting a review from Amazon from A Gartland regarding this "clicking"

http://www.amazon.com/review/R26RF6QR247S70/ref=cm_cr_pr_perm?ie=UTF8&ASIN=B001SEQN3K&nodeID=&tag=&linkCode=

"For anyone who uses a 64-bit operating system and experiences a clicking sound with this headset when music gets a bit more bass in it, I think I've found a fix. It's worked for me so hopefully if you have this problem it should work for you. I know this isn't a review but I came here first when i had the problem to see if others had it also so I assume others might do the same.

Right click on the volume icon in the system tray and click "playback devices". Click on the headset then press "Properties". Go to the Enhancements tab, check the "Bass Boost" box. (This seems counter-intuitive but bear with me, this does work). Once you've checked the box, click "Settings". Set the Boost Level to "None". Here's the important bit; set the frequency to 100 Hz. If this only partially fixes the issue for you, try different frequencies until it works for you.

Hope this helps someone."

 

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,
have you solved this problem by now?

I just got a .655 myself and I have the same problem. I'm on Windows XP and hope that someone can help me out.

Thanks in advance.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I had read that review before but it didn't help unfortunately.


Thanks anyways Munster :)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.