Audio playback through headphones and speakers

Headphones or speakers in windows 7, Can't have both?

Looked over the other questions, nothing seemed close.

My machine was dual boot, XP and Vista ultimate, now XP and Windows 7. In both XP and Vista I could have the speakers and the headphones plugged in together, both playerd noise, and I could use one or the other by plugging them into the front and back audio jacks.

This enables me to play games during day with speakers, and then at night with head phones, and no reaching round under my desk to remove cables.

Now I am using windows 7 and amongst the many other problems I have with it, I can't play with speakers or headphone until I have gone through a silly lot of clicking to disable one or choose the other as default. Why has this been changed in windows 7 after Vista, it seems an utterly pointless logic. I can turn my speakers off with the power button and get the headphones working. Now I am either or. So my brand new IR head phones are wasted. Please someone tell me there is a work around?

It's little meddling silliness like this that make me want to remain in XP.

Much thanks in anticipation someone has figured a work around.

 
Question Info

Last updated August 15, 2018 Views 529,976 Applies to:
Answer

I've got both my Jabra GN9350 and my laptop speakers playing audio at the same time. :)

 

Here's the trick (and it's been verified on 3 other Win 7 systems):

1) R click on your speaker icon, select 'Recording Devices' (if you have the sounds dialog up, it's the 2nd tab 'Recording')

2) R click in the white space, be sure that BOTH "show disabled devices" AND "show disconnected devices" are checked.

3) **Now this step is going to take a little bit of thought for each computer being used: on my laptop (HP Elitebook) I get a device "Stereo Mix", ENABLE this device.

4) Click on Properties, go to the tab 'Listen'

5) Check the box "Listen to this device", also change the drop-down box below "Playback through this device" to be your second audio device

-- To verify that you've done this correctly, go back to the Sound dialog tab Playback, you should now see both of your audio devices showing the little green graphs moving.

 

Here are the specific settings that I have on my laptop, maybe this will help with your settings:

Speakers- GN9350 (Default Communications Device)

Speakers- SoundMAX Integrated Digital HD Audio (Default Device)

Stereo Mix- 'Listen' feature points this  device to my GN9350 headset.

 

Paul

121 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Right. Your hardware has not found a driver that works in Win 7. You will have to keep checking for updates for that to use the device in Win 7 the way you want it.
Rating posts helps other users
Mark L. Ferguson MS-MVP
Rating posts helps other users
Mark L. Ferguson (former MVP)

29 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.