Audacity Win7 does not record sound

I tried to follow the instruction at http://win7mag.com/?p=151 to use Audacity (and Audiograbber) to record streaming audio from IE8.

All devices are showing including disabled.

However, WaveMix is not a choice.  So I selected Stereo Mix Reltek High Definition Audio as the default device.  (actually I tried all the choices for recoding devices that didn't say Not Plugged In).  When I play music using IE 8 I can hear the music out of my speakers but after hitting the Record button in Audacity I just get a flat line (no recorded sound).  My sound card in Creative SB X-Fi and update driver says I have the latest driver (7/15/09 6.0.1.1323).

Is it possible to use Audacity to record streaming audio in Win7 (fully updated)? YES or NO?

If yes, any ideas what I am doing wrong?   Thanks.
 

Question Info


Last updated September 14, 2019 Views 19,090 Applies to:
Answer
Answer
I have a desktop box with the PCI Express Sound Blaster X-Fi Titanium Fatal1ty Champion Series sound card installed. 

I finally got Audacity to work.  I had previously run Windows Update and was told I had the latest drivers.

However, when I ran Creative Sound Autoupdate it found a whole host of new drivers for my sound card software.  I install 400+ mb of files.
Now Windows Media Player produced no sound.  I changed Playback to Speakers and Recording to What U Hear and sound returned for the media player.
AND Audacity recorded the sound from the Media Player and also streaming sound from the Internet.

Hope this helps some body else.

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.