Windows Media Player 12 - Dead Duck

Hi,

Been there, tried that, still no joy.  Used "Method 1" and "Method 2" I found here.  Downloaded a load of new codecs.  Updated video drivers.  Turned off harware acceleration, turned it back on again.

WMP still crashes whenever I try to play a file.  I cam open WMP, and even see the library items.  Just can't play them.  I have Win 7 Home Premium 32 bit.  Athlon 4000+, 2 Gb RAM, Geforce 6800GT video card.

WMP works fine on the other PC (lesser spec and same card).  I suspect something is corrupted in my version of Win 7.  Any suggestions gratefully recieved, please!  I have downloadedVLC, but I just want to get this long-standing problem sorted.  IIRC, WMP 12 has never run corrrectly on this machine.

Many thanks!

Jon

 

Question Info


Last updated March 15, 2018 Views 2,310 Applies to:
Answer

Hi Debleena,

 

Thanks for the suggestions.  I have tried Method 1 just now and have deselected all the start up items other than MS.  WMP12 is still failing.

 

I ran SFC and it reports that it found corrupted files, but could not fix them.  Having a view of CBS.log seems to point at mf.dll.  I have tried to delete this DLL and replace it with another from a known good Win7 machine.  Permissions prevent me doing so - we have 2 accounts on this machine but I am admin.  It wants trusted installer (Me!) to do the deleting or copy/replacing.

2010-06-06 18:02:45, Info                  CSI    000001a1 Hashes for file member \SystemRoot\WinSxS\x86_microsoft-windows-mediafoundation_31bf3856ad364e35_6.1.7600.16385_none_9c35855f6e153ff4\mf.dll do not match actual file [l:12{6}]"mf.dll" :

 

I have also just tried Method 3 and no joy.  WMP12 is still dead.  I'd like to try and replace the mf.dll, as this looks like the likely culprit. How may I get permission to swap it out with a good version, please?  It would be really easy to re-install WMP12 from the MS website, but I'm not being allowed to do that.

 

UPDATE:

 

SUCCESS!!!!

 

I took mycopy of MF.DLL from a known good installation and dropped the file on my desktop.  I then followed the instructions here:

http://support.microsoft.com/kb/929833/en-gb

How to use the system file checker.

From that document I took the following advice, and pasted the lines into an Admin-Run Command Prompt:

If the System File Checker tool cannot repair a file, follow these steps:

 

  • At an elevated command prompt, type the following command, and then press ENTER:
    takeown /f <var>Path_And_File_Name</var>
    For example, type takeown /f E:\windows\system32\jscript.dll .
  • Type the following command, and then press ENTER to grant administrators full access to the file:
    icacls <var>Path_And_File_Name</var> /GRANT ADMINISTRATORS:F
    For example, type icacls E:\windows\system32\jscript.dll /grant administrators:F .
  • Type the following command to replace the file with a known good copy of the file:
    Copy <var>Path_And_File_Name_Of_Source_File </var> <var> Path_And_File_Name_Of_Destination</var>
    For example, type copy E:\temp\jscript.dll E:\windows\system32\jscript.dll .

copy C:\users\abc123\desktop\mf.dll c:\windows\system32\mf.dll

File was copied OK and WMP12 is working.  I'll reboot with all the services restored, adn hopefully we'll get there.

 

In summary, System File Checker highlighted the dodgy DLL, and the Knowledgebase article enabled me to take permission of, and replace the corrupted MF.DLL

 

Many thanks for your help.  I hope this solution helps someone else!!

 

Jon

 

 

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.