Won't sleep automatically with network files open

I have a windows 7 HTPC.  All my content (photos, videos, etc is stored on my WHS).  The Windows 7 Media Center is set to point to the WHS for photos etc.

Problem is that once the screen saver starts up in Media Center, it prevents the computer from entering the sleep state.  The monitor shuts off like it is supposed to, but the computer will not sleep.  The computer will sleep fine automatically if Media Center is closed.

When Media Center is open I have run powercfg -requests and see many entries similar to this one:

[DRIVER] \FileSystem\rdbss
A file has been opened across the network. File name: [\SERVER\Photos\Vacation\11767.jpg]

One I have close Media Center, these entries no longer appear in powercfg -requests and the system can sleep as it should.

I enjoy using the picture slide show for a screen saver and would prefer not to have to disable it to get this to work.  Is there any other way?


Question Info

Last updated July 12, 2019 Views 8,711 Applies to:
I've determined that it is not just with the screen saver, but after I have accessed any of my photos in media center.  I have found this post that seems to suggest making a registry edit to allow sleep with remote files open will solve the problem.  Is this the only way?


From the post:

to show the hidden power property that can allow a system to sleep whilst network shares are open

You can either set this via the Group Policy Editor (gpedit.msc), or you can enable it to appear in Power Properties by opening Regedit and going to:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ Control\ Power\ PowerSettings\ 238C9FA8-0AAD-41ED-83F4-97BE242C8F20\d4c1d4c8-d5cc-43d3-b83e-fc51215cb04d]

In there, set Attributes to 0 (the default value is 1, which means hide)."

5 people were helped by this reply


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.