Windows Update service consuming 100% load on single core (Windwos 7)

Hi,

this week Monday Windows update service (wuauserv) is constantly consuming 100% load of a single core. The system is completely up-to date, all updates are applied. I know that Windows update in general is sort of crappy software (sorry guys, but there's a lot of room for improvement) and usually consumes high CPU for a long time just to scan for updates (installation usually also takes very long time), but this time it simply does not stop.

Restaring the service did not help. Reboot did not help either. I tried to re-install all com-Dlls, restarted service, ... nothing helped. Then I tried applying the appropriate Fixit tool but this this tool seems to be quite 'clever' and starts wuauserv service in order to detect problems --> same load again.

My system is Windows 7-64 and usually is very fast (Core-I 7, 2.6 GHz, 8 GB Ram, 512GB SSD) so it's NOT the PC.

Thanks,

KE

 

Question Info


Last updated March 14, 2018 Views 1,167 Applies to:
Answer
Answer

Some additional general information, since this topic got referenced to from another website: In case setup of KB3161608 returns "The update is not applicable to your computer", its prerequisite, KB3020369, is missing.

"To apply this update, you must install [...] April 2015 servicing stack update for Windows 7 and Windows Server 2008 R2 (KB3020369)."

Regards, VZ

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.