Windows Update doesn't work- - wuauserv has 50% cpu utilization

Windows 7 SP1 problem

I am new to this Form - just found it when doing searches. I have a problem, maybe someone can help.

I recently did a clean install of Windows 7 SP1 64 bit. I am having a problem with Windows update. At first it wouldn’t work. It would get stuck on “Checking for Updates” - never got past this first step. I also noticed Windows Update service program “wuauserv” would have about 50% cpu utilization even without windows update running. I searched the Windows Community Forum and  found others are also having similar problems with high cpu utilization for wuauserv.

One of the recommendations was to install a fix - windows6.1-KB3138612 which I did. Windows Update worked at first and allowed 211 updates to be installed. However, now Windows Update is back to getting stuck on “Checking for Updates” and still a high cpu utilization for wuauserv.

Another recommendation is to have Microsoft .Net framework 4.5.2 installed which the most consistent ( doesn’t say the most current, says the most consistent). I have 4.5.2 installed.

Attempting to resolve this problem, so far I have:

  1. Installed fix windows6.1-KB3138612 as noted above.

  2. Ran windows update diagnostic program which fixed “Service registration missing or corrupt” and two other programs. One problem could not be fixed -“Windows Update error 0x80070057(2016-05-T-o8_12_02A)”

  3. Tried to run Windows Update in safe mode and with a clean boot. It would not start.

     4.Ran system file checker - (sfc /scannow) It didn’t find any bad files.

     5.  Ran MicrosoftFixit50123 - it didn’t do anything

It seems many are having this problem but there doesn’t seem to be a resolution for it. There are many posts from years past and recent about wuauserv having high cpu utilization.

Does anyone have any words of wisdom or have had the problem? When will this be fixed?  

Thanks,

Martin   


 

Question Info


Last updated March 14, 2018 Views 2,580 Applies to:
Answer
Answer

The first update (KB3153199) did not have a 64 bit update, only a 32 bit update was available.

Please use this link:

https://www.microsoft.com/en-us/download/details.aspx?id=52232

Regards, VZ

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.