Question

Q: Windows Search Service is not running (Window 7)

I am running Windows 7 64 Bit.
Everytime i try to seach i am prompted to turn on indexing, and i do.
Because this is a reoccurring event i investigated further in the indexing options.
Indexing options says "indexing is not running" and and only allows me to enter advanced options.
Automatic trouble shooting futher gives me error measage "Windows search service not running" ... "Not fixed".
I have checked the services and tried to force start this service and get "Error 3: The system cannot find the path specified".

Can someone help me with this service?

Answer

A:

Windows 7 Security is a PIA and is what my problem was. "Indexing not running" and my inability to start theWindows Search service persisted despite all of these suggestions above and more.

When I went into C:\ProgramData\Microsoft\Search\Data and Took Ownership of it (http://www.howtogeek.com/howto/windows-vista/add-take-ownership-to-explorer-right-click-menu-in-vista/), I was able restart the service Windows Search. Thereafter, Indexing ran and worked.

One must set the securities of the ProgramData directory (C:\ProgramData) in order to stop this ____ from interfering with the installation of programs and often the proper execution of programs and services. Right Click on C:\ProgramData and select Security, then set the permissions to allow yourself full permissions (http://www.blogsdna.com/2159/how-to-take-ownership-grant-permissions-to-access-files-folder-in-windows-7.htm) and the problem goes away permanently. (Note C:\ must be your Window's path otherwise use your default root.)

Thanks Microsoft Support for your irrational, frustrating security measures and the fact that your support team doesn't have a clue. You haven't been able to write a user friendly OS since XP and arguably since MSDOS. Too bad that I hate Apple more than you.

6 hours of BS to figure this out.

I hope it works for you.

Did this solve your problem?

Sorry this didn't help.

50 people were helped by this reply



 
Question Info

Views: 120,879 Last updated: May 18, 2018 Applies to: