Windows 7 won't go to sleep when on battery power

I recently replaced the laptop battery on my Acer 5517 inspire running windows 7. On battery power when I leave Internet explorer 11 running (and maybe some an other programs) the computer won't go sleep after a while...it just stays on until the battery runs out and doesn't even hibernate when critical battery level is reached. The computer works fine and will go to sleep after 30 minutes when plugged in or when I have it on battery power with no applications running. This problem is frustrating because if I forget to plug in my computer and leave a program running the next morning I have to restart windows and get the message windows didn't shut down properly. I am frustrated because the system does hibernate correctly when the battery reaches a critical level during the certain conditions I mentioned but when on battery power and an application running it does not hibernate when critical battery level is reached.
 

Question Info


Last updated November 14, 2019 Views 15,714 Applies to:
Answer
Answer

Hi Cory,

Sorry for delay in reply.

 

PCs may not enter sleep mode when using internet over the network. Windows is designed not to do it by default when you are streaming any video or audio from internet.

 

First, launch a Command Prompt window using the "Run as administrator" option. (Search for "cmd", right-click and select "Run as administrator".)

 

Then run this command:   powercfg -requests

 

What this will do is tell you any programs or devices that are currently preventing the system from entering sleep mode. In case, it reported that my audio device was causing the issue. The message was "An audio stream is currently in use."  This could be caused by something as simple as a web browse that has some Flash content in it.  See screenshot...

 

 

 

So now that you know what is preventing Sleep mode, you need to tell the power management system to ignore that device and go ahead and enter Sleep mode anyway.  In my case, it was my audio card called "High Definition Audio Device".  Yours will vary - it might mention Creative Labs, SoundMax, RealTek, etc. Or it might be a totally different device all together (network card, mouse, keyboard, etc.).  You'll need to specify that exact same name in the following command.

 

For me, the command was:   powercfg -REQUESTSOVERRIDE DRIVER "High Definition Audio Device" SYSTEM

 

Now that I've told the power management system to ignore any audio streams opened by that device, it goes to sleep without any problems.

 

Hope this helps. Let us know if you need further assistance with Windows.

John Rubdy
Forum Moderator | Microsoft Community

24 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer

Hi Wkrueger,

Sorry, to know that you are facing this issue.

According to Power Configuration report it seems that there is an issue with USB drivers. Let’s try this methods and check if it helps.

If you are using Windows 8 refer this article: USB devices could rarely enter into selective suspend on Windows 8

Try the below mentioned methods and see if it helps.

Method 1: Try to run Power Troubleshooter which is built in troubleshooter and you may follow the steps mentioned below to run it.

  1. Click Start, click on Control panel.
  2. In the search box of Control Panel type Troubleshooter, and select troubleshooting among the list.
  3. Under System and Security, click Improve power usage.
  4. Now try to run the troubleshooter and check if it helps. 

Note: If you're prompted for an administrator password or confirmation, type the password or provide confirmation. 

If issue persist, proceed to next method.

Method 2: If issue persist, I would suggest you to Reset and restore the power plans to default.

  1. Press Windows key and X at the same time.
  2. Choose Command Prompt (Admin) from the context menu.
  3. In the command prompt, type powercfg –restoredefaultschemes and hit Enter.
  4. Exit command prompt. 

Note: This would reset the power plan settings to default. Any customized power plans would be removed.

If issue persist, proceed to next method.

Method 3: You may check if the option to “Allow the computer to turn off this device to save power” is enabled and enable the option.

To check the settings follow the steps below:

1. Type in Device Manager into the start menu search box Press enter.
2. Scroll down to “USB” and find your USB device.
3. Right-click on it and choose Properties from the menu. In the dialog box, choose the Power Management tab.
4. Check the box next to “Allow the computer to turn off this device to save power” and “Allow this device to wake the computer”.
5. Click on Apply and Ok.

Also try updating the Graphic card and chipset drivers from your computer manufacturer website.

Update a driver for hardware that isn't working properly ...

Hope this helps. If you need further assistance with Windows, let us know and will be glad to help.

John Rubdy
Forum Moderator | Microsoft Community

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.