Windows 7 support has ended

Get Windows 10 to continue receiving support.

Upgrade now

Windows 7 will not shut down or restart my computer. I have tried every suggestion I've seen previously posted.

My computer shuts down fine with Vista (64-bit), but not with Windows 7 (Home Ultimate, 64-bit).  It logs me off and brings up the "Shutting down" screen, accesses the hard drive as if it's doing something, but never shuts my computer (or monitor) off.  It does this same thing when I tell Windows to simply restart my computer.  I always have to hold down the power button to shut off.  Occasionally, next time I boot up I'll get a message saying the computer was unexpectly shut down, but usually not.  Although I don't feel like this problem is physically damaging my computer, it's still an annoying problem.

So far I have tried:

- Changing ACPI settings in my BIOS.  I don't have the ability to enable/disable ACPI, only to change between 1 & 3.  I've tried both.

-Microsoft's "Clean Boot" method for troubleshooting.  Even with all non-critical services and startup items disabled I still have this problem.

-Disabling Windows Fax.  One person had this issue, and so I thought I'd give it a shot.  No good.

-Another forum suggested disabling the M-Audio card.  Tried it.

-Yet another forum suggested changing the "power settings" in Device Manager for the IEEE1394 Bus Controller, by enabling the computer to shut down the computer, or something along those lines.  I see no options anywhere to change power settings.

Any new suggestions I can add to the list?

Answer
Answer

After reading a lot on the forums and trying almost everything, hotfixes, disabeling energy saving features on ieee1394 and usb. It hit me, everything points to the acpi on the motherboard and the mps table. Changing mps table from 1.4 to 1.1 in the bios solved the problem and win 7 shutsdown properly

ET1

 

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer
Well that's weird!  I tried disabling my card again (a 1010LT) and I was able to shut down!  Maybe some other random thing I ended up disabling was also hanging the shutdown.  Here's what I'm trying right now based on a couple recent suggestions on the M-Audio forums:

1.  Reinstalling current (Vista64) driver.

If that doesn't work

2.  There's a Win7 beta driver.  I'll give that a shot. 

I'll give an update in about 30 minutes once I know whether either option works.

____________________________
UPDATE (and my answer):

Option 1 didn't work.

Option 2 DID work.  I downloaded & installed the beta driver from here:

http://forums.m-audio.com/showthread.php?t=11130  -- you have to register to download, but it's quick & free

I did a cursory check in Sonar and it seems to be working just fine.  I can shut down & restart Windows.  Yay!  Jackisback, let me know if that works for you.

17 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated June 18, 2020 Views 133,521 Applies to: