Windows 7 Explorer.exe not starting when I boot my PC up.

Hello,
I want to start off by stating that about 4 months ago I had this same problem with my computer where my explorer.exe would not automatically run when i boot my pc up. After manually running explorer it would stay "not responding" for ~15-20 min there after and I couldn't even use the pc during that time. This was when I was running Windows Vista.

I fixed the problem by doing a clean install with Windows 7 and mostly everything was smooth, until this morning.
I boot my pc and up popped an automatic update from logitech for my keyboard/mouse software (new setpoint application). So I installed it and was recommended to restart my pc.
So I restarted it and walked away for a second only to come back and see a black screen, I knew right then that the problem occurred again. I had to manually boot up the explorer and wait ~20 min for it to start responding.
I ran a system restore to the night before and it removed the newly installed setpoint program but still had the explorer problem.

Side note:
This may come to some help. Even though I never had explorer.exe problems prior to this with windows 7, my internet doesn't start working until about 15-20 minutes before I boot my computer up either, it's almost like there is a hold somewhere in my system. It runs fine on other computers on the network, however, my pc seems to have that 15-20 min no response time on the internet.This problem has been happening for weeks. I will ask about this problem in another post however I figured it may help to fix my problem.

Thank you in advance
Jordon

Answer
Answer


Hi,

Welcome to Microsoft answers.


1. Let's first start the computer, once the comp boots to the desktop, press Ctrl+Alt+Shift to bring up Task manager
2. Under Processes tab, check if the explorer.exe process is running
3. If it's not, then cilck File-> New Task, type explorer.exe and click OK.

 Once it is done, check for these steps:

 Start > Run , type in   'regedit'    (without the quotes of course) in the search box .


(can also get run by going Ctrl+Alt+Del>file>NewTask (run))


Go to the following in the registry editor:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon.  

In Winlogon, on the right side, there should be a value called "Shell".
Double click this value.  Make sure only 'Explorer.exe' is the value of Shell, if anything else is there , simply delete it and leave 'Explorer.exe' .
Restart the computer for the changes to take effect.

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs

I suggest you to download and install WSE, scan for the trojans

Thanks and Regards,

Azam – Microsoft Support.

 

 

 

 

 

 

 

 

88 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated November 2, 2020 Views 162,928 Applies to: