Windows 7 backup freezes

I just switched from Vista Home Premium to Windows 7 Ultimate.  I used to be able to backup my hdd to an external hdd but now it freezes up and will not move.  The icon on the task bar says "backup in progress" although it has been several days.  I deleted the old backups and even changed the drive letter.  Nothing seems to work.  Any help would be greatly appreciated! Thanks!

Question Info

Last updated July 10, 2019 Views 16,392 Applies to:

Hi Royce128,

Thank you for visiting Windows 7 community.


This issue occurs if some components cannot be copied. I suggest that you temporary disable the anti-virus and firewall. If you still face the same problem, then open the folder C:\Windows\Logs\WindowsBackup.  When you start backup, a log file "Backup Files*_error.log" will be generated. Please open the file when backup hangs.


If there is no valuable information in the log, please open the folder C:\Windows\Logs\CBS, copy the file CBS.log and paste to Desktop. Then open the file CBS.log on Desktop, check the last part of this log to try to find which file cannot be backed up during backup process.


If the issue persists even after disabling firewall and anti-virus then let’s disable all startup items and third party services when booting. This method will help us determine if this issue is caused by a loading program or service. Please perform the following steps:


Step 1: Perform a clean boot

Note If the computer is connected to a network, network policy settings may prevent you from following these steps. We strongly recommend that you do not use the System Configuration utility to modify the advanced boot options on the computer unless a Microsoft support engineer directs you to do this. Doing this may make the computer unusable.


1. Log on to the computer by using an account that has administrator rights.

2. Click StartCollapse this imageExpand this , type msconfig.exe in the Start Search box, and then press ENTER to start the System Configuration Utility. Collapse this imageExpand this imageIf you are prompted for an administrator password or for confirmation, type your password, or click Continue.

3. On the General tab, click Selective Startup, and then click to clear the Load startup items check box. (The Use Original Boot.ini check box is unavailable.) 

4. On the Services tab, click to select the Hide all Microsoft services check box, and then click “Disable all”.

Note: Following this step lets Microsoft services continue to run. These services include Networking, Plug and Play, Event Logging, Error Reporting, and other services. If you disable these services, you may permanently delete all restore points. Do not do this if you want to use the System Restore utility together with existing restore points.

Click OK, and then click Restart.

After doing these steps, follow the second step from the KB article mentioned below:

NOTE: After finishing all the steps in the KB article, restart your computer in normal mode. Follow these steps:


Reset the computer to start as usual

After you have finished troubleshooting, follow these steps to reset the computer to start as usual:

1. Click StartCollapse this imageExpand this im, type msconfig.exe in the Start Search box, and then press ENTER. Collapse this imageExpand this imaIf you are prompted for an administrator password or for confirmation, type your password, or click   Continue.

2. On the General tab, click the Normal Startup option, and then click OK.

3. When you are prompted to restart the computer, click Restart.

For more information on backup procedures, you may visit the following KB article:



Let me know if this worked.

Hope this is helpful.



Vijay K - Microsoft Support

Visit our Microsoft Answers Feedback Forum and let us know what you think.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.