Windows 7 Aero Disabled Due to Performance

Hello All

This is a recurring issue that has been posted on those forums many, many times. I want to pose the question though, honestly Microsoft, for power users such as myself and the myriad others that have asked for an option to disable this "feature" where Windows disabled the Aero desktop theme because of system performance - why have we not seen any sensible response? 

Here are my specs

Mobo: MSI 890GXM-G65
CPU: AMD Phenom X6 @ 3.3GHz
RAM: 16GB DDR3-1600
GFX: Radeon HD 6950 2GB GDDR5
HDD: 1TB SATA 6GB/7200RPM

Running on a 25" 1080p LCD @ 75hz

Honestly, my rig can handle just about anything short of Crysis on Ultra. Give me a way to disable this nonsense about performance. I am tired of it. Stop taking power away from your power users, it does you no good. There's no fix, there's no setting my PC to "Adjust for Best Appearance"; I've tried all this for years now. If nothing else, tell me the registry key I can go change to stop this nuisance from happening. It has to be the most annoying thing I have ever seen from a Windows release, going back to before Windows 95. The longer this goes unfixed, the closer we get to true gaming on Linux, the less time you have. Your power users will cease to exist. Give us a fix or something to disable this.

Hi,

Thank you for writing in Microsoft Communities. 

 

I would suggest you to try the steps provided and check if they help in resolving the issue.

 

Method 1: Run Windows Aero Troubleshooter. Follow the steps in the link below:
http://windows.microsoft.com/en-us/windows7/Open-the-Aero-troubleshooter

 

Method 2: Also I would suggest you to update video card driver for hardware and check if the issue still persists.

Update a driver for hardware that isn't working properly:  http://windows.microsoft.com/en-us/windows7/Update-a-driver-for-hardware-that-isnt-working-properly

 

Note: If you don’t find the drivers in Windows updates, go to manufacturer’s website download the latest drivers and install it.

 

Please perform these recommended steps provided and post back if you are still experiencing the issue.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Thank you for writing in Microsoft Communities. 

 

I would suggest you to try the steps provided and check if they help in resolving the issue.

 

Method 1: Run Windows Aero Troubleshooter. Follow the steps in the link below:
http://windows.microsoft.com/en-us/windows7/Open-the-Aero-troubleshooter

 

Method 2: Also I would suggest you to update video card driver for hardware and check if the issue still persists.

Update a driver for hardware that isn't working properly:  http://windows.microsoft.com/en-us/windows7/Update-a-driver-for-hardware-that-isnt-working-properly

 

Note: If you don’t find the drivers in Windows updates, go to manufacturer’s website download the latest drivers and install it.

 

Please perform these recommended steps provided and post back if you are still experiencing the issue.



This is not the issue.  

I have run the Troubleshooter, it finds no issue as there is no issue.

My drivers have been updated multiple, multiple times, it is not the issue.

There is no issue with the performance of my machine.

The issue is this: Windows 7 rates performance based on CPU load and memory use, among other parameters; some video games and programs will push ANY machine to its limit. Once this limit is hit, Windows automatically disables Aero features in an attempt to free up system resources. This is pointless if you are a user like myself and you know WHY your resources are being maxed. I know precisely WHY this problem occurs and there is no fix for it short of buying new parts and severely upgrading my machine and that will only put a bandaid on the problem for a short time.

New games in this world will push any machine to its limits at some point, especially when alt-tabbing out of a full-screen game. What I need is not a solution to the resource problem, because Windows/Microsoft will never have that solution; I need an option to DISABLE THE AUTOMATIC DISABLING OF AERO FEATURES.

I just need a little checkbox in my Performance Options that says "NEVER disable Aero features regardless of system performance" 

Do whatever it is you need to do to have this implemented.

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Thank you for writing in Microsoft Communities. 

 

I would suggest you to try the steps provided and check if they help in resolving the issue.

 

Method 1: Run Windows Aero Troubleshooter. Follow the steps in the link below:
http://windows.microsoft.com/en-us/windows7/Open-the-Aero-troubleshooter

 

Method 2: Also I would suggest you to update video card driver for hardware and check if the issue still persists.

Update a driver for hardware that isn't working properly:  http://windows.microsoft.com/en-us/windows7/Update-a-driver-for-hardware-that-isnt-working-properly

 

Note: If you don’t find the drivers in Windows updates, go to manufacturer’s website download the latest drivers and install it.

 

Please perform these recommended steps provided and post back if you are still experiencing the issue.



This is not the issue.  

I have run the Troubleshooter, it finds no issue as there is no issue.

My drivers have been updated multiple, multiple times, it is not the issue.

There is no issue with the performance of my machine.

The issue is this: Windows 7 rates performance based on CPU load and memory use, among other parameters; some video games and programs will push ANY machine to its limit. Once this limit is hit, Windows automatically disables Aero features in an attempt to free up system resources. This is pointless if you are a user like myself and you know WHY your resources are being maxed. I know precisely WHY this problem occurs and there is no fix for it short of buying new parts and severely upgrading my machine and that will only put a bandaid on the problem for a short time.

New games in this world will push any machine to its limits at some point, especially when alt-tabbing out of a full-screen game. What I need is not a solution to the resource problem, because Windows/Microsoft will never have that solution; I need an option to DISABLE THE AUTOMATIC DISABLING OF AERO FEATURES.

I just need a little checkbox in my Performance Options that says "NEVER disable Aero features regardless of system performance" 

Do whatever it is you need to do to have this implemented.

Try following tips:
New ways to speed up your PC: (This is based on my experience) You won't be disabling Aero effect!!!
 
Go to control panel then click on Ease of Access then click Optimise Visual Display then in Make my computer easier to see in the make things on the screen easier to see section, check the box for Turn off all unnecessary animations (where possible) then click apply then OK!

If your graphic card is not fast or good enough then also try this one:
Go to Control Panel again then click on User Account and Family Safety then User Accounts then click on Change User Account Control Settings then move the slider to just above Never notify. the second position from bottom. This will not dim the display anymore But it will still notify you!

Go to control panel then click on Ease of Access then click on change how your mouse works then in Make it easier to manage windows section, check both check boxes for activate a window by hovering over it with the mouse and Prevent windows from being automatically arranged when moved to the edge of the screen. Then click on Apply then OK!
 
Go to My Computer, Then Click on System Properties then go to Advanced System Settings then go to Advanced tab then in Performance section, click on Settings button then in Visual Effects either choose Adjust for Best Performance Or if you like to have both good looking and performance then click on custom then uncheck all check boxes except the forth, fifth, sixth and last three check boxes then click apply then OK then again OK. You may require to restart or log off for changes to take effect.
After performing above tips, your Windows 7 will run much more faster than before. You will feel it straight away!

My blog: http://safeworldwidewebsurfing.blogspot.co.uk/

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

My blog: http://safewordwidewebsurfing.blogspot.co.uk/


No. Those are not valid options nor will they do anything to alleviate this stupid "feature" of Windows 7.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Thank you for writing in Microsoft Communities. 

 

I would suggest you to try the steps provided and check if they help in resolving the issue.

 

Method 1: Run Windows Aero Troubleshooter. Follow the steps in the link below:
http://windows.microsoft.com/en-us/windows7/Open-the-Aero-troubleshooter

 

Method 2: Also I would suggest you to update video card driver for hardware and check if the issue still persists.

Update a driver for hardware that isn't working properly:  http://windows.microsoft.com/en-us/windows7/Update-a-driver-for-hardware-that-isnt-working-properly

 

Note: If you don’t find the drivers in Windows updates, go to manufacturer’s website download the latest drivers and install it.

 

Please perform these recommended steps provided and post back if you are still experiencing the issue.



This is not the issue.  

I have run the Troubleshooter, it finds no issue as there is no issue.

My drivers have been updated multiple, multiple times, it is not the issue.

There is no issue with the performance of my machine.

The issue is this: Windows 7 rates performance based on CPU load and memory use, among other parameters; some video games and programs will push ANY machine to its limit. Once this limit is hit, Windows automatically disables Aero features in an attempt to free up system resources. This is pointless if you are a user like myself and you know WHY your resources are being maxed. I know precisely WHY this problem occurs and there is no fix for it short of buying new parts and severely upgrading my machine and that will only put a bandaid on the problem for a short time.

New games in this world will push any machine to its limits at some point, especially when alt-tabbing out of a full-screen game. What I need is not a solution to the resource problem, because Windows/Microsoft will never have that solution; I need an option to DISABLE THE AUTOMATIC DISABLING OF AERO FEATURES.

I just need a little checkbox in my Performance Options that says "NEVER disable Aero features regardless of system performance" 

Do whatever it is you need to do to have this implemented.

If you want Aero NOT to be disabled regardless of what you do then you have to do this
Go to My Computer, Then Click on System Properties then go to Advanced System Settings then go to Advanced tab then in Performance section, click on Settings button then in Visual Effects either choose Adjust for Best Appearance!!
Sometimes if it is disabled automatically, then that means your graphic ram (2GB) is full as you are running too many programs that require graphic ram at same time and it is NOT a problem for you  to run them all at once as you have lot of physical RAM.
During the Windows Index test the Aero is disabled to rate your computer hardware based on Maximum Performance they can achieve on their own NOT together therefore your windows index experience is the lowest number so that all hardware can achieve good performance based on that score! 
Is this what you looking for?

I assume that you are looking for both performance and appearance which is hard to achieve on Windows these days. But most people prefer performance to appearance! That is why they test windows based on Performance because if your performance rating is high then obviously everything should work together nicely.
 
The Physical ram won't help to improve your graphic performance as you already have highest score, I have 8GB and It is already 7.8 which is 0.1 less than 7.9 max score.
Now I have also 2GB for my graphic card my score is 6.7. Now you can see the difference here:
6.7 vs 7.8 which means my physical ram achieve much better performance than my graphics card but if i want both the I have to stick with lower score which is 6.7 which is not the best yet! My disc transfer rate has even lower score of 5.9 which means if I want all together work nicely then I have to stick with 5.9!!!!

Therefore even if you have high score in processor and ram, your performance score for graphic card will degrade them down if it is being used! 
Hope above make sense!



Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It makes sense, sure but... that's not the point. I do not care about the performance rating. I know WHY it happens. What I want is an option to ignore the performance rating and keep my Aero theme regardless of system performance

This is not hard to do, it can't be. You've had 6+ years to fix it, Microsoft and you haven't. I have seen this exact same thread on these boards hundreds of times. And all you engineers keep suggesting the same things which do nothing to fix the issue. The issue is not system performance. It is the lack of an option to ignore it. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It makes sense, sure but... that's not the point. I do not care about the performance rating. I know WHY it happens. What I want is an option to ignore the performance rating and keep my Aero theme regardless of system performance

This is not hard to do, it can't be. You've had 6+ years to fix it, Microsoft and you haven't. I have seen this exact same thread on these boards hundreds of times. And all you engineers keep suggesting the same things which do nothing to fix the issue. The issue is not system performance. It is the lack of an option to ignore it. 


Yes, I undrestand your point too now. Well, I can not help you on that!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm having the same issue. My rating is 7.8 I've got amazing hardware and this is still happening and does not make sense. I want this option as well. never ask to disable Areo would be so nice =D

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated August 23, 2020 Views 3,276 Applies to: