Windows 7 64-bit hangs/freezes on file transfers

I've been dealing with this issue for about a year now.  I've searched the internet and found dozens of forums where people have had the same problem, but no one seems to know how to fix it, or what the real cause is.  I've tried innumerable solutions, I can't even remember them all.  I'm making one last ditch effort to solve this before I start replacing hardware, which I don't want to do because I'm broke.

The problem is that randomly Windows 7 64-bit will hang and/or freeze during file transfers.  It can be something as simple as browsing the internet (small cache files), moving files on the computer, or downloading huge multi-gigabyte files.  The OS will hang, and programs will start to become unresponsive ("Not Responding").  If I open the Resource Monitor, there is 100% Highest Active Time (the blue line) on the drives doing the file transfer, but hardly any actual disk activity at all.  The disk activity LED light is on 100%, but nothing is happening.  In fact, the file transfer pauses during this time.  The mouse is still responsive, and some windows are still active, but start to go unresponsive as you click on them.  After anywhere from 1-3 minutes the computer will go back to normal, the blue line in the Resource Monitor drops back down, and file transfer activity resumes as if nothing happened.  Occasionally this will cause the OS to freeze, and the only solution is to reboot.

That's the gist of it.  I've tried all sorts of things to remedy this, but nothing seems to work.  Please let me know what to try, and I'll let you know if I've done it, or give it a go.

Here are the specs of my machine:
  • Windows 7 64-bit SP1 (clean install)
  • ASUS P6T Motherboard (latest 1408 BIOS)
  • Intel Core i7-920 Bloomfield 2.66GHz Quad-Core Processor
  • CORSAIR XMS3 6GB (3 x 2GB) 240-Pin DDR3 1600 (PC3 12800) Triple Channel Kit TR3X6G1600C9
  • EVGA 512-P3-N954-TR GeForce 9500 GT 512MB PCI Express 2.0 x16 Video Card (latest nVidia drivers)
  • Intel X25-M Mainstream SSDSA2M080G2XXX 2.5" 80GB SATA II MLC Internal Solid State Drive (SSD) (latest firmware)
  • LG DVD Burner Black SATA Model GH22NS50
Any help would be greatly appreciated.  Please, if you know what might be the issue here, let me know.  I think my next step if I don't find a solution is to replace the motherboard (bad disk controllers?).

Question Info

Last updated May 13, 2019 Views 14,912 Applies to:
I just replaced my Intel SSD hard drive with a Seagate 1TB HDD, and I haven't seen the problem since.  Could it be that the Intel SSD was causing the problem?  Why would it do that?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.