Random freezes with windows 7 - 64 bit

I use to run Vista home premium x86 on a acer computer. This summer I downloaded Windows 7 rc x86. A month ago I bought all new parts and since I could use 64-bit system now I installed a 64-bit Windows 7.  Then did the problem start. Every new and then the computer freezes, some days over 30 times. I thought it was hardware problem and tried a lot of hardware finders and nothing helped. I also installed windows 7 rc my mothers laptop (The same version I use to have that work fine) that used to run on Vista home basic.. But her computer didn’t freeze it just got a black screen now and then.

The I started to suspect that it was because it was a beta version so when windows 7 were released I bought two of them a 32-bit and a 64-bit. But the problem didn´t go away. It´s still there and It´s kind of frustrating and even more now when I’m trying to write a essay.

I used windows upgrade advisor and it didn´t see any problem with an upgrade to windows 7. What can I do?

original title: Random freezes with windows 7

 

Question Info


Last updated November 21, 2018 Views 517,044 Applies to:
Answer
Guys,

I might have the answer to your problems.  This might fix your sleep/suspend problems and your random freezing problems.  Bottom line is that the default and "auto" values in Win 7 and your BIOS might not produce a stable computer...even with a virgin install.

RANDOM FREEZES FIX:
My computer used to freeze randomly until I fixed the memory timings.  I suspected bad memory early on and tested it with MEMTEST, but it passed with flying colors.  I even tried swaping memory out, trying to eliminate bad memory and/or slots.  It turned out that it was a memory frequency/timings/voltage issue.  No more freezes!  If you have a similar setup, this will most likely fix it.  If not, then check your memory and/or power supply.

The "AUTO" settings in BIOS *may not* produce a stable setting.  You have to goto the ASUS support website and download the latest memory QVL and lookup the memory settings for your particular brand there.  For my memory (OCZX1333LV6GK(XMP)) I had to make the following adjustments in the BIOS:

DRAM Freq:1066  (even though my memory is rated at 1333 frequency, the QVL guide recommended a lower freq!)
7-7-7-16 for the rest of the timings.  The other settings I was able to leave in "AUTO"
DRAM BUS Voltage: 1.6
*warning: be sure to consult your memory/motherboard documentation...the wrong value could damage your components!


SUSPEND/SLEEP FIX:

My computer used to hang when coming out of sleep or wouldn't completely goto sleep.  This solution may be partially dependent on you fixing a random freezing issue if you have one. 

In your "advanced" power settings, disable "Hybrid Sleep".  That's it!  My motherboard doesn't like hybrid sleep.

*If you have a desktop with a UPS, Win 7 will treat it like a laptop and apply the battery settings....sooo make sure you adjust the "on battery" settings!



My setup:

Processor:Intel core i7 920
Motherboard:Asus P6T
Memory: OCZX1333LV6GK(XMP)    (ie. 6GB in 3 sticks)
Harddrive:  3 x WD Caviar Black drives in RAID 5
PSU: X3 1000W
Video card: 2 x NVIDIA 9800 GTX+ SLI


*I have all of the ASUS overclocking/energy savings programs uninstalled
*I have the latest BIOS 0801 and all the latest drivers installed

Nick

35 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.