PC becomes slower after a few hours.

I've taken a look at my graphics card (1GB DDR3 ASUS ENGTS250), my processor (Intel Core2 Quad Q9550 (2.88Ghz)), my motherboard shouldn't cause this problem, I have 4 gigs of ram and I've recently upgraded the power supply. This is a very strange issue as when I restart the PC (after this lagging stage) it will run perfectly after the startup. I can only assume that it's a problem with Windows.

No, I don't have a virus, yes, I have checked. Yes, I have run the PC optimization troubleshooter and yes, I have run other Windows optimizing programs. Yes, I have cleaned out the registry. Yes, I have removed unwanted startup items. Yes, I have run a defrag. Yes, I have tried formatting and re-installing Windows.
 

Question Info


Last updated June 18, 2019 Views 8,024 Applies to:

Hi,
have you had a look at how the files-indexing is set? If it's set to too large a number of files / directories, it might slow down everything. As far as I know, the indexing startup is delayed by default, so it starts / continues a few minutes after the system has booted-up.
Other hypothesis: a program in automatic execution, or a service, has a delayed startup and, for some reason, slows down the computer afterwards. You could try to switch off all the unneeded services, and see if it changes anything.
A suggestion, in order for the Microsoft Support guys to give a better answer to you: can you describe with more details what happens, and can you try to quantify the "slow-down"?

Regards

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey, thanks a lot for the hints. How do I look at how the files-indexing is set?

I've made sure to check any unwanted services and remove them. The wierd thing is, it doesn't happen over a set time, it will just get slower and slower untill it becomes unbareable and I simply have to restart. I notice this because I'm usually playing a game and after a couple of hours playing it, the game will lag. After a few more hours the game lags excessively and about an hour after that, it takes seconds to shift from one screen to the next. And it's not only with games, opening windows explorer, Office or other programs takes MUCH longer after these hours.

Thanks again.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

start -> computer -> right-click on "C" drive -> Properties -> General -> uncheck the option "index unit" or something like that (sorry, I'm not English, my Win7 is in Italian...); in the further dialog box, click on "apply to unit C:\, to all folders and to all files" (or something like that).

If you have more than one disk, repeat the procedure for each one. If you want to exclude a single directory, you can do the same but from an Explorer window and right-clicking on the directory's name, I presume (never tried).

This is a bit radical, but if you know well where your files are, you can get rid of the indexing... In fact, it "only" speeds-up search.

The behaviour you have seems in fact a bit strange, because by default Win7 is very conservative with the indexing, because he knows that it can slow-down the system (so by default he indexes only a few directories)... My computer has been running for two days uninterruptedly and it is still as responsive as at boot-up...

Regards

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Well thanks a lot for that, cloche. Although it took a LONG time processing, it hasn't seemed to have solved the problem. I originally thought it might be that there's some junk on my PC, but there's actually MORE memory space when it's lagging than when it's not and LESS processing usage too. I thought it might've been the video card, but that too is colder. I tried overclocking it, also didn't help. Something to note is that I never got this problem with Windows XP. Could this by an issue with my particular copy of Windows?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Bumping this up and just adding on: Sorry, removing the indexing actually has helped! But I didn't realise untill after the restart. Now it's wierdly lagging on and off, never as bad as it was before though, so I'm doing a few more tests just to make sure that it was the indexing that was the problem.

Thank-you very much, cloche!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.


Eliminate Viruses and Spyware
1
Run your antivirus program. There may be something slowing your computer that you can remove. It is a good idea to run your antivirus program every week.

2
Remove spyware. Run a good spyware tool at least twice a month.

3
Use a pop-up blocker, if you have one. Check your antivirus program.

Dispose of the Extras
1
Delete your document files for anything you no longer need. Saved pictures, audio and video files in particular can slow your computer.

2
Remove unwanted programs from the Control Panel area. Old toolbars or games the kids downloaded off the Internet are a good place to start. Look for software you no longer use, such as the old printer you threw out last year.

3
Clean out your email. Old messages are a constant drain on your computer's resources. Go through every folder, deleting everything you do not need. Leave no mail! Finish by emptying the Deleted Items folder.

4
Turn off unnecessary programs. Check your taskbar for icons that show running programs. Disable anything you are not currently using.

Run Maintenance
1
Run the Disk Cleanup tool located in your Control Panel. (Windows only. For other operating systems, please check the Resources section below.) This will remove temporary files, cookies and unnecessary components to speed up your computer.

2
Defragment your computer. Defragging takes some time, but will speed your computer significantly. You can find the tool in your Control Panel. Run it monthly.

3
Check for disk errors. Sometimes corrupted files slow down your computer. To find and fix these files, Go to My Computer and right-click on C drive. Choose Properties, then Tools.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello Allyd,

Please note that posting SPAM in any Microsoft forum violates theCode of Conduct. Kindly read the document and adhere to its policies. We have modified the post in question, but please know that you risk being banned from posting in all Microsoft forums if violation continues. Thank you for your cooperation


Adam
Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us know what you think
My CPU is a neural net processor, a learning computer.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.