ndis.sys (DPC) consuming 50+% CPU when notebook disconnected from power line.

When I installed Windows 7 x64 Ultimate (before that I used Windows XP x86) I received problem. When I disconnect power cord from my notebook (HP Compaq 8710w) 1 CPU's kernel become very high usage. Even mouse pointer moves with leaps. 

I tried to investigate problem with Process Explorer and founded, that DPC loads CPU over 50%. 

I continue my investigation and after running 

xperf -on latencyxperf -I \kernel.etl -a dpcisr

I received next results:

 

--------------------------
DPC Info
--------------------------
CPU Usage Summing By Module For the Whole Trace
CPU Usage from 0 us to 29476196 us:
CPU 0 Usage CPU 1 Usage 
usec % usec % Module
11245 0.04 10371 0.04 ACPI.sys
58 0.00 0 0.00 ADIHdAud.sys
108 0.00 85 0.00 HDAudBus.sys
36 0.00 0 0.00 HTTP.sys
485 0.00 0 0.00 NETIO.SYS
13 0.00 0 0.00 Ntfs.sys
1944 0.01 1699 0.01 SynTP.sys
751 0.00 0 0.00 Wdf01000.sys
1127 0.00 0 0.00 afd.sys
117 0.00 0 0.00 btwaudio.sys
125 0.00 0 0.00 btwavdt.sys
10 0.00 0 0.00 cng.sys
1 0.00 0 0.00 fltmgr.sys
293 0.00 511 0.00 i8042prt.sys
20 0.00 0 0.00 luafv.sys
14832013 50.32 18357 0.06 ndis.sys
302 0.00 0 0.00 netbt.sys
926 0.00 0 0.00 nm3.sys
11413 0.04 6791 0.02 ntoskrnl.exe
41579 0.14 46201 0.16 nvlddmkm.sys
23 0.00 0 0.00 rdbss.sys
111 0.00 168 0.00 sple.sys
28 0.00 14 0.00 srv.sys
2 0.00 0 0.00 srvnet.sys
3916 0.01 103 0.00 tcpip.sys
286 0.00 0 0.00 tunnel.sys
6740 0.02 4550 0.02 "Unknown"

 

As you can see the problem with standart Network Driver Interface Specification driver (ndis). 

Another information:

  • Mobile DualCore Intel Core 2 Duo T7700
  • Intel Crestline-PM PM965
  • 4032 Mb  (DDR2 SDRAM)
  • NVIDIA Quadro FX 1600M  (512 Mb)
  • Intel(R) 82566MM Gigabit Network Connection
  • Intel(R) Wireless WiFi Link 4965AG


Intel 82566MM Gigabit Network, has "latest" driver (e.g. an effort to update the driver says I'm using the latest one) Intel 9.13.12.0 (05.06.2009)

Intel Wireless WiFi Link 4965AG, "latest" driver (e.g. an effort to update the driver says I'm using the latest one) Microsoft 12.4.1.4 (26.03.2009). WiFi disabled, so problem is not with this driver. 

 

Also installed Microsoft Network Manager 3.3. No other software, firewalls, antiviruses, network hacks or other settings changes installed. 

Problem appear randomly if disconnect network cord and after that disconnect power cord (notebook still works on battery). It don't means on what power plan it works. Problem appear on all power plans. Also if problem appear one time it was not solved until hibernate or reboot. I mean, that every time when I disconnect power cord problem appear (when I connect power cord again problem resolves), and I can do this as many times as I want. 

Problem solves by hibernate (after unhibernate there is no high CPU usage) or reboot. And appears again randomly.

Now I uninstall Microsoft Network Manager and will try to check if problem solved or not during some time.  

 

 

Question Info


Last updated August 26, 2019 Views 7,530 Applies to:
Which power mode (high performance, power saving) did you select for your WLAN in the power plan? And which power plan do you use?
"A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Bug_Finder,
 
Lets make sure that all the advanced power options are set to never, to do that follow the steps below.
 
a. Open Power Options by clicking the Start button , clicking Control Panel, clicking System and Security, and then clicking Power Options.
b. On the Select a power plan page, click Change plan settings next to the selected plan.
c. On the Change settings for the plan page, click Change advanced power settings.
d. On the Advanced settings tab, double-click Sleep, double-click Sleep after, and then do one of the following:
• If you're using a laptop, click On battery or Plugged in (or both), click the arrow, and then click Never.
• If you're using a desktop computer, click Setting, click the arrow, and then click Never.
e. Double-click Hibernate after, and then do one of the following:
• If you're using a laptop, click On battery or Plugged in (or both), click the arrow, and then click Never.
• If you're using a desktop computer, click Setting, click the arrow, and then click Never.
f. If you also want the display to stay turned on, double-click Display, double-click Turn off display after, and then do one         of the following:
• If you're using a laptop, click On battery or Plugged in (or both), click the arrow, and then click Never.
• If you're using a desktop computer, click Setting, click the arrow, and then click Never.
g. Click OK, and then click Save changes.
 
If the above provided steps doesn’t resolve the issue then you may check the event viewer for the errors.
 
Follow this below link to know more about event viewer.
 
I also suggest you to run the advanced tools to troubleshoot performance problems in Windows 7.
 


Thanks and Regards:
I. Suuresh Kumar - Microsoft Support.

Visit our Microsoft Answers Feedback Forum and let us know what you think.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

 

I've had the same problem with ACPI.sys using as much as 60% on one core of my CPU. I'm using Windows 7 x64.

The problem occured only after I put the system on "sleep". After few hours the system spontaneously woke up and I noticed the high CPU usage.

I discovered that ACPI.sys+0x1af44 thread was responsible (using sysinternals ProcessExplorer).

Since it happened after waking up from sleep I went through Event Viewer to see what triggered the resume.

The result: "Wake Source: Device -Intel(R) ICH10 Family PCI Express Root Port 5 - 3A48"

Proceeded to device manager to see what was on that port and voila: "Realtek PCIe GBE Family Controller" was shown.

Next I disabled the option in Power Management for the device: "Allow this device to wake the computer"

Immediately the CPU usage went to normal (without restarting).

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

I'm having this problem too on W7x64. After coming out of sleep mode, and waiting for system to stablize, there is then an endless cycle of cpu usage spikes about every 5 seconds, spike width about 2 seconds. This behaviour repeats until rebooting. Xperf DPC CPU usage shows ndis.sys ndisMTimerDpcX is consuming the most time.

Note that this problem only occurs when more than one core is enabled (from boot config).

Narrowed down problem to Intel network card drivers by toggling disabled/enabled status in device manager.

Updating drivers fixed the problem. Note: had to go to Intel website to get latest driver because the "Update Driver" functionality in Device Manager doesn't search very far - not even the Intel website. So, moral of this tail - don't rely on DM to search the web for a driver!!

Regards,

Darren

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.