Disable external USB drive autoplay? Windows 7 Pro.

I have two USB external drives connected to my computer. Every time I boot up, an Autoplay window appears for each drive asking me what I want to do with it. It gives 2 choices of "Open folder to view files", or "View more AutoPlay options in Control Panel". If I select to view more AutoPlay options, my USB drives are not listed at the bottom of AutoPlay under devices. I want to continue using AutoPlay for my CD/DVD drives, but I want to stop the AutoPlay windows from appearing every time I boot the computer. It is frustrating to have to click the X on both of these windows every time I boot the computer.

Any suggestions?

 

Question Info


Last updated October 14, 2019 Views 59,696 Applies to:
Answer
Answer
So, i faced the same problem with my external HDD 1TB. I read all the replies here but none of them helped. Here is the solution that worked for me.

First make vissible all hidden folders and files.
To make this follow:

1.Click Organize ---->Open Folder and search Options---->Click View


To Show Protected Operating System Files
NOTE: For example, desktop.ini files.

    A) Uncheck the Hide protected operating system files box.

    B) A Warning message appears,click on Yes to confirm.

    C) Click OK


2. To Show Hidden Files, Folders, and Drives
NOTE: This will also allow hidden drives to show despite if Hide empty drives in the Computer folder is checked.

    A) Select  Show hidden files, folders, and drives.

    B) Click on the Apply button.

Open your HDD
Check if there is a folder named autorun.inf
Check if there is a file named autorun.inf
Delete both of them.
Then create a new folder with name autorun.inf and leave it empty.

In case you don't like to see the folder make these few steps.
 
To super hidde this folder open a command prompt.
Click Start and in search type cmd.

Then go to your HDD root.
For example we assuming that the drive letter of the disk is E.
You must type.
E:\
E:\attrib e:\autorun.inf +s +h

That's it,close command prompt and hidde again your hidden files and folders.

Restart your computer and see if it worked.



4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer

I have two USB external drives connected to my computer. Every time I boot up, an Autoplay window appears for each drive asking me what I want to do <snip>, but I want to stop the AutoPlay windows from appearing every time I boot the computer. It is frustrating to have to click the X on both of these windows every time I boot the computer.

Any suggestions?


Click the START orb and in the search box type "regedit" (no quotes).  <enter>.
Click once on COMPUTER (top-left) then click the EDIT menu and click on FIND.

Type "NoDriveTypeAutoRun" and <enter>.
 In the left-hand pane right-click on EXPLORER and click on EXPORT.
 Type in "autorun" into the FILE NAME box, choose a folder of your choice and press the SAVE button.
 
 Back in the registry editor, in the right-hand pane, right-click on the NoDriveTypeAutoRun entry, and click MODIFY.
 Change the number 91 to 95.   Press OK.

 Reboot.  If no joy, double-click the file that you saved, to merge it back into the registry.

14 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.