DCOM error 10016 in event viewer / windows 7 home premium, 64bit

I get this error :

 

The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID

{C97FCC79-E628-407D-AE68-A06AD6D8B4D1}

and APPID

{344ED43D-D086-4961-86A6-1106F4ACAD9B}

to the user NT AUTHORITY\SYSTEM SID (S-1-5-18) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.

 

This error shows up every time I start or reboot my PC. I found out the CLSID is from the IPBusEnum service.

I get the same error in my other windows 7 PC as well. It startet around april 2011...I assume it has to do with some microsoft updates.

What I did so far:

I went into component services and tried to change security settings for IPBusEnum...but everything is grayed out.

I went into registry and changed ownership and permission for this key....still greyed out!

I added NETWORK SERVICE in component service/my computer/properties and gave full permission to everything....still greyed out!

I went into services and changed the status of PnP-X IP Bus.. to Manual so it wouldn't start...still get the error.

I changed service to Automatic...and error went away...but the service changes back to the initial status of Automatic/delayed start after every reboot.

 Before  the SP1 update the service was set to Manual...I don't know why it is on auto/delay now.

I think I tried every solution I could find online, but for me somehow nothing works....

 

Anybody has the same proplem and found a fix?

Answer
Answer
Unfortunately, the link you provided doesn't solve the problem entirely. (It's also for Windows XP. Is there an equivalent Windows 7 article?) It misses the key problem the OP has (and I had)... "I went into component services and tried to change security settings for IPBusEnum...but everything is grayed out."

The following is what I had to do before I could grant permissions to the COM component:

1.    Make sure you’re logged on as an administrator.
2.    Click Start, type regedit in the Search bar, then click regedit.exe
3.    In the Registry Editor, press CTRL-F, type {344ED43D-D086-4961-86A6-1106F4ACAD9B} and click “Find Next”.
4.    The first result is located in HKEY_CLASSES_ROOT\AppID\. This is the key we need.
5.    Right-click the key {344ED43D-D086-4961-86A6-1106F4ACAD9B} in the left sidebar, and then press “Permissions…”
6.    We first have to change the ownership of the key. The current owner is TrustedInstaller. We have to change the owner to Administrators. Therefor, click Advanced. Then go to the tab Owner, select Administrators, check the box “Replace owner on subcontainers and objects”  and press OK.
7.    Now that we have changed the ownership to ourself (member of the Administrators group), we can change the permissions on the registry key. In the Permissions window, grant Administrators AND SYSTEM Full Control permissions. Then click OK to confirm the changes. In these 8 steps, we have granted the Administrators and SYSTEM account full permissions to the key HKEY_CLASSES_ROOT\AppID\{344ED43D-D086-4961-86A6-1106F4ACAD9B}.
8.    Verify that in this key, the value of LocalService is IPBusEnum
9.    Click Start, type Component in the Search box, and then click Component Services
10.    In the Component Services window, go to Computers –> My Computer –> DCOM Config. Right-click IPBusEnum and click Properties.
11.    Go to the tab Security. In the Launch and Activate permissions section, select Customize and click Edit.
12.    Select SYSTEM, select the permissions checkbox “Local Launch”. Then click OK to apply the change.
13.    Done!

Credit for this solution goes to
http://www.itexperience.net/event-10016-the-application-specific-permission-settings-do-not-grant-local-launch-permission-for-the-com-server-application-with-clsid-c97fcc79-e628-407d-ae68-a06ad6d8b4d1/

43 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated August 5, 2020 Views 36,291 Applies to: