Question

Q: Computer auto restarts when entering hibernation and sleep

I have installed win 7 Home Premium on both my laptop and Desktop recently.  The Laptop works fine with no issues, however, I cannot put the desktop into hibernation or sleep mode either manually or automatically. On Manual, it tries to close down then, just as it is about to switch off, you hear the HDD start up again and you end up back at the desktop or sign in page!!  Originally, after installation there were no issues with this mode but I suspect, that a program or driver installed subsequently, has caused the problem.  


I have tried the following action without success:


 

  • Reinstalled drivers for sound and vision
  • changed advanced power settings 
  • Switched off hybrid sleep
  • Disabled USB selective suspend settings
  • Hard Drive switches off 2 mins. before computer enters hibernation
  • Flashed BIOS

 

Answer

A:

Hi,

Welcome to Microsoft Vista answers Forums!

let's first check if the system supports the feature

 

  1. Click Start , type command in the Start Search box, right-click Command Prompt in the Programs list, and then click Run as administrator.

If you are prompted for an administrator password or for confirmation, type your password, or click Continue.

  1. At the command prompt, type powercfg /a. 

Check the output of the command

Also you may follow these below steps.

 

A hardware device might be keeping your computer awake. USB flash drives and USB mice are common devices that can keep your computer awake. Make sure that you have the most current drivers all of your devices.

To prevent a device from waking your computer

1.      Open Device Manager by clicking the Start button , clicking Control Panel, clicking System and Security, and then, under System, clicking Device Manager. If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

2.      In the list of hardware categories, find the device that you want to prevent from waking your computer, and then double-click the device name.

3.      Click the Power Management tab and then clear the Allow this device to wake the computer check box.

4.      Click OK.

A program or scheduled task might be waking your computer. By default, Power Option settings do not allow scheduled tasks to wake the computer from sleep or hibernate. However, some programs might awaken the computer if these settings have been changed.

To prevent programs from waking your computer

5.      Open Power Options by clicking the Start button , clicking Control Panel, clicking System and Security, and then clicking Power Options.

6.      On the Select a power plan page, click Change plan settings for the plan that you want to change.

7.      On the Change settings for the plan page, click Change advanced power settings.

8.      On the Advanced settings tab, expand Sleep, expand Allow wake timers, choose Disable for both when your computer is running on battery and when it's plugged in, and then click OK.

Also you may refer this below link for further information.

 

http://windows.microsoft.com/en-US/Windows7/Sleep-and-hibernation-frequently-asked-questions

 

Thanks and Regards:

Suresh Kumar- Microsoft Support.

Visit our Microsoft Answers Feedback Forum and let us know what you think.

Did this solve your problem?

Sorry this didn't help.

1 person was helped by this reply



 
Question Info

Views: 14,987 Last updated: July 9, 2018 Applies to: