Monitor shuts off on me

My computer monitor keeps shutting off on me.  I have a dell inspiron b130 (i know it is kinda old) but i don't think its a hardware issue.  it has started happening since i installed windows 7.  at first i thought it was because my original product key didn't work, but i did the automated phone activation, and validated on the website, but it still shuts off.  If i don't use my computer for awhile, it may stay on for a good 20 mins or so, but once it shuts off once, the time it stays on gets less and less.  but, i just close the lid and open it back up and it works again...any ideas as to what is going on?!?

 

Question Info


Last updated March 15, 2018 Views 624 Applies to:
Answer

Hey Noseph,

 

Does the system stay on while the monitor shuts off?

 

Or is it the entire system that shuts off?

 

Does it happen while performing a particular activity or is the behavior consistent?

 

Next time this happens, check if your laptop is overheating as this can behavior can very much relate to it.

 

This problem is also most likely related to the fact that there is no driver available for Windows 7 for your laptop. However before coming to that conclusion, check for Power Management settings. See if you’ve configured any such settings. Remove the plans and test the monitor.

 

Refer the Windows help article given below on how to achieve this.

 

Change, create, or delete a power plan (scheme)

http://windows.microsoft.com/en-US/windows7/Change-create-or-delete-a-power-plan-scheme

 

 

Finally, if nothing helps the issue most likely points to the Graphics card not running on proper driver.

 

I see that you have Intel GMA900 graphics card which has Windows XP driver so far. Run the driver in compatibility mode. See where it takes.

 

Download either from:

 

http://support.dell.com/support/downloads/driverslist.aspx?os=WW1&catid=6&dateid=-1&impid=-1&osl=EN&typeid=-1&formatid=-1&servicetag=&SystemID=INSPIRON1300%2FB130&hidos=WW1&hidlang=en&TabIndex=&scanSupported=False&scanConsent=False

 

or

 

 

http://downloadcenter.intel.com/SearchResult.aspx?lang=eng&keyword=%22GMA900+%22

 

You may choose to run Program Compatibility troubleshooter or manually change the compatibility settings.

 

Refer:

 

Make older programs run in this version of Windows

http://windows.microsoft.com/en-us/windows7/Make-older-programs-run-in-this-version-of-Windows

 


Regards,

Shinmila H - Microsoft Support

Visit our Microsoft Answers Feedback Forum and let us know what you think.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.