Windows 7 support has ended

Get Windows 10 to continue receiving support.

Upgrade now

you do not have permission to access \\PC_NAME contact your network administrator to request access

I have read several posts in forums that address this error message and tried all solutions to no avail.

Here are my troubles.  I have three computers all running Windows 7 Home Premium and a Sony PS3 all connected wirelessly to my home network via a Belkin N router.  All internet connectivity works fine, all printer connectivity works fine.  All of the computers and PS3 can access files through the network and home group with each other fine . . . except for one, My Laptop.  My Laptop can access files on all computers in home group and they can all access each others files in homegroup, but none can access the files on My Laptop.  Every machine that I try to access the files on My Laptop produces the error message; "you do not have permission to access \\LAPTOP  contact your network administrator to request access"

Help Please, I've tried every adjustment that I have read about, assuring proper TCP protoccols, making sure homegroup settings allow access, making sure files are shared, disabling firewalls, disabling Kaspersky, adjusting sharing settings etc etc ad nauseum.  Nothing helps.

Please . . . my brain is starting to hurt.

 

Question Info


Last updated May 22, 2020 Views 43,944 Applies to:
Answer
Answer

Hi

Maybe this can Help.

Permission and Security issues with Vista/Win7, check the following settings.

All users that are allowed to share need to have account on all the computers that they are allowed to connect to.

Everyone is an account, it means a group of all of the users that already have an account and been established as users.

Using the Everyone feature saves the need of configuring permission to each of theestablished users, it does not mean Everyone that feel that they would like to login. 

Users that do not have an account on the computer are Not part of the Everyone Group.

If security on the LAN is Not needed and users are Not established, then switching On the Guest account provides semi-open configuration.

http://windows.microsoft.com/en-US/windows7/Turn-the-guest-account-on-or-off

---------------------

Point to the a Folder that meant to  to be share. Right click and choose properties.

In the properties

Click on the Security tab shown in the pic bellow to the right) and check that the users and their permission (shown in the pic bellow center and left) are correctly configured. Then do the same to the Permission tab.

This screen shot is from Win 7, Vista's menus are similar.


In both the Security panel, and the Permission panel you have to highlight each User/Group and examine that the Permission Controls are checked correctly.

When everything is OK, Reboot the Network (Router, and computer).

* Note . The Groups and Users shown in the screen-shoot are just an example. Your list will look the way your system is configured. 

 


Jack - Microsoft MVP, Windows Networking. WWW.EZLAN.NET
Jack MVP, Microsoft Windows Desktop Experience-Networking.

www.EZLAN.net

9 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.