xp does not have permission to access win 7 shares

i have 3 desktop computer. 1 with windows 7 64bit  wired to router, one with xp32 bit wired to router and one with xp 32 bit wireless. in old set up i had 2 xp's and a vista 32 bit and everything worked fine. now the windows 7 comp can see the 2 xp's on the network and can accss shared folders and file and use printers. the 2 xp's can access shared files and folders and printers with eachother but not with the windos 7 comp. the xp machines can see the win 7 comp in the homegroup. but when i try access it they say "ps is not accessible, you might not have permission to use this network resource". 

the settings on the win 7 computer are

Network typpe: work

Network Discovery: on

Printer and File Shareing: on

Public Folder Sharing:on

Media streaming:on ( i haven;t touched this setting at all yet)

File Sharing connection: 40 or 56 bit incryption

password protected shareing: off

the work group name is the same on all computers.

 

i need to be able print from all computers through the win 7 comp and i need to be able to share files back and forth with one of the xp comps and the win 7 comp

|
Answer
Answer

Hi

Win7 when configured on peer-to-peer Network has three types of Sharing configurations.

HomeGroup Network = Works only between Win 7 computers. This type of configuration makes it very easy to Entry Level Users to start Network sharing.

 Work Network = Basically similar to the previous methods of sharing that let you control what, how, and to whom folders would be shared with.

 Public Sharing
= Public Network (like Internet cafe) to reduce security risks.

 For best results log to each computer's System Screen and set all the computers to be on a Network with the same name while each computer has its own unique name.

http://www.ezlan.net/Win7/net_name.jpg


Make sure that the Software Firewall on each computer allows free local traffic. If you use 3rd party Firewall On, Vista/XP Native Firewall should be Off, and the active Firewall has to adjusted to your Network IP numbers on what is some time called the Trusted Zone (consult your 3rd Party Firewall instructions

General example,  http://www.ezlan.net/faq#trusted

Please Note that some 3rd party Software Firewalls keep blocking aspects of Local Traffic even it they are turned Off (disabled). If possible configure the Firewall correctly, or totally uninstall it to allow clean flow of local network traffic. If the 3rd party software is uninstalled or disables, make sure that Windows native Firewall is On .

Since you have a Network with Win 7 and other version of Windows you need to configure Win 7 as Work Network.

In the Network Center, clicking on the Network type opens the window to the right.

Choose your type of Network. Notice the check mark at the bottom, and check/uncheck it according to your needs.

http://www.ezlan.net/Win7/net_type.jpg

Win 7 - http://windows.microsoft.com/en-us/windows7/Networking-home-computers-running-different-versions-of-Windows

Win 7  Work Network specific folder sharing - http://www.onecomputerguy.com/windows7/windows7_sharing.htm

Vista File and Printer Sharing- http://technet.microsoft.com/en-us/library/bb727037.aspx

Windows XP File Sharing - http://support.microsoft.com/default.aspx?scid=kb;en-us;304040

Printer Sharing XP - http://www.microsoft.com/windowsxp/using/networking/expert/honeycutt_july2.mspx

Windows Native Firewall setting for Sharing XP - http://support.microsoft.com/kb/875357

Windows XP patch for Sharing with Vista (Not need for XP-SP3) - http://support.microsoft.com/kb/922120

When finished with the setting of the system it is advisable to Reboot all the hardware including the Router and all computers involved.

*Note. Some of the processes described above are done Not for Windows sake but to compensate for different Routers and the way their firmware works and stores the info about the computers that are Networked.

 


Jack, MVP-Networking. EZLAN.NET
Jack MVP, Microsoft Windows Desktop Experience-Networking.

www.EZLAN.net

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Answer
Answer

hey, thanks, i actually figured it out a few hours after i posted, sorry for the late reply, it was the stupid mcaffee 2010 firewall. i check when this probelm first happend and it said that all ip adresses from 1.1 to 1.255 were set for work access. i figured this was the right setting and didn;t worry about it. after much frustration and messing around i shut down the fire wall and instantly everything worked. so instead of playing around with "ports and System Services" like it tells you to on Mcaffee's help site. i just went to there tech support and let the guy change the firewall setting for me. you have to go into connewction in the firewall setting and add the ip's you want and set them to "home" access. 3 damn days of head aches and holding up the buissiness for one tiny little setting. almost every computer these days shares files or printers with other computer, mcaffee shoudl make it a little more obvious or promt you or something for firewall setting that allow you to access othe rcomps. 

thanks anyway for the fast reply

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated December 11, 2018 Views 2,933 Applies to: