XP and Vista or Windows 7 two PC cross-over ethernet cable network problem

I have Laptop Gateway MT6821 vista Home Premium SP2 (and then also tried Windows 7 Ultimate) and Desktop Dell GX280 XP SP2. I connected them via an Ethernet cross over cable. Try these settings:

1)
In both way (password protected sharing and non-password protected sharing) I used identical user accounts on both PCs (same user name and password).
2)Same workgroup “WORKGROUP”
3)Open the “File and printer sharing” in vista or Windows 7 from Network and sharing center
4)Change to “private network” or “home” from “public network” in Vista or Windows 7 respectively
5)On Folders and Root Drives Sharing > advance sharing > permission> everyone > full control in vista or in Windows 7 share a file.
Also I ran XP Home Networking Wizard etc.

6) Network and Sharing Center > Manage network connections. > Right-click > Properties > Configure > Power Management tab > clear the Allow the computer to turn off this device to save power > OK
7) Installed the Link-Layer Topology Discovery (LLTD) protocol on that XP computer.
8) In Vista or Windows 7 Computer have enabled LLTD, >Network and Internet, >Network and Sharing Center, > Manage network connections. > The network adapterProperties > Link-Layer Topology Discovery Mapper I/O Driver andLink-Layer Topology Discovery Responder checked the boxes> OK.
9) Checked the Windows firewall settings and make sure that “Enable file and printer sharing” are enabled in XP.
10) Both computers’ network adaptors were set to obtain IP, DNS etc. automatically.

Now after doing these setting my vista was indicating normal icon in Taskbar (two diagonally overlapping computer with animation), but my XP computer indicating yellow tag on that icon (Limited or no connectivity error). However I can ping them vice versa and Vista is mapping the XP computer.

But the problem is that I can’t access the XP computer from Vista or Windows 7 although it was mapping in vista or 7, and my XP even wasn’t seeing Vista or 7 computers. I tried to access each of them by computer name e.g.
\\LAPTOP.... But all were coming up to an error; you don’t have permission etc…..

Then I tried one by one
11) Same IP sequence (10.1.1.1, .2) and same subnet (255.255.255.0) mask on both computer
12) Disable Windows firewalls on both computers
13) Or turn off the password protected sharing from vista and 7 > network and sharing center > password protected sharing > off
I have read all articles of Vista XP networking from Microsoft. But there is no hope; can anyone tell me what is wrong with me?

 

On XP:
Only windows firewall

and on Vista or Windows 7:

Windows firewall
Avast Antivirus

 

 

Question Info


Last updated October 23, 2018 Views 6,410 Applies to:
Answer

The Node Type of Peer-Peer is not going to let my resolve network addresses without a WINS server.
John Will suggested me to do this:
http://forums.techguy.org/7454078-post12.html


"Create a file in notepad named NODETYPE.REG with the following contents:

You should have 3 boxes on the bottom in NOTEPAD.
1)Filename : NODETYPE.REG
2)Save as type: all files
3)Encoding: ANSI
If you do not change it from txt type to All files type, then the file will actually be NODETYPE.REG.txt, this won't accomplish the desired result.

------------------- Use text after this line -------------------
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBT\Parameters]
"NodeType"=-
"DhcpNodeType"=-
------------------- Use text before this line -----------------

Double click on the file and say Yes to the merge into registry question.

Reboot the computer."


then I restrated my windows 7 after this registry edit, all is working correctly. Now have connected to my desktop by my built in laptop network adaptor, and I am usning internet by my USB SMC network adaptor. I have on file shared on my laptop and deskop shared drive permission is set to "Full" however have restricted the number of simultanous user limit to "1".Is it ok?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.