Q: wireless network adapter gone missing

Hi -

I've seen a number of similar questions but no solutions to my problem. 

My system:
Toshiba A505-S6980
Windows 7 Home Premium - 64bit
Realtek WLAN driver

After resuming from a sleep, the network adapter dissappeared.  This happened before and they replaced the computer, after trying a system restore and then full recovery.  Apparently, it's not the computer. 

The Wireless adapter is missing from device manager, much less the network and connections area.  In troubleshoot, the computer simply says a network cable needs to be plugged in.  There is no wireless choice under network connections.  There is no wireless adapter tab upon right click of Network Adapter in Device Manager. 

The Realtek WLAN driver DOES appear in the Programs & Features list.  I uninstalled, reinstalled, and also found/installed a patch for the driver.  This did not work.  I also started/automated the Autoconfig scripts for wireless.  Nothing works. 

Any help is appreciated. 




Hi '

This just happened to me and I was able to get past it by doing several hard reboots. I had to fully charge the battery , and after three attempts with increasing intervals of time, the system appearently turned the wireless adapter back on.

After the card reappeared, I was able to find it in device manager again, in my case Intel(R) Centrino(R) Wireless-N 2200 under network adapters . Then a right click, to properties , within properties you chose power Management tab. There you will probably discover that by default the computer is allowed to turn off this device to save power. Uncheck the box , click ok and reboot . Hopefully this will prevent it from happening again.

Hope this helps

Art Master T

Did this solve your problem?

Sorry this didn't help.

312 people were helped by this reply



This same thing happened to me. What causes it to happen is a very low battery but found a simple solution to turn back on the wireless network adapter.

Hold down the Windows key and press x

menu should come up

click device manager

should go to a list of devices on your computer

expand network adapters from list

might be a few to choose from but look for 2 with the same name. one for wifi and one for ethernet

double click on the wifi network adapter

click on power management tab

click off the tab that allows the wifi to be turned off with low battery

click on drivers tab and enable device

should be good to go from there

Did this solve your problem?

Sorry this didn't help.

288 people were helped by this reply

Question Info

Views: 309,608 Last updated: June 19, 2018 Applies to: