Windows XP / Windows 7 cannot communicate on my home network

I have an existing home network with 2 xp machines that can "see" each other on my home network. I have just connected a newer windows 7 PC and athought it connects to the internet it cannot "see" either xp machine and the xp machines cannot "see" it. All machines have the same workgroup name (WorkGroup). But the win 7 machine seems to exist in a vacuum. Help!

Answer
Answer
In Windows 7, go to Control Panel>All Control Panel Items>Network and Sharing Center. Click on "Change advanced sharing settings". You don't want to use Homegroup unless you have all Windows 7 machines. If you do and you want to use Homegroup, see Windows 7's Help & Support. Otherwise, in the Advanced Sharing:

Turn ON network discovery
Turn ON file and printer sharing
Turn ON sharing in the Public folder sharing section
Turn ON password protected sharing

A. Configure firewalls on all machines to allow the Local Area Network (LAN) traffic as trusted. With Windows Firewall, turning on Windows 7's File and Printer Sharing as above will take care of this for you. If you aren't running a third-party firewall or have an antivirus/security program with its own firewall component, then you're fine.  With third-party firewalls, I usually configure the LAN allowance with an IP range. Ex. would be 192.168.1.0-192.168.1.254. Obviously you would substitute your correct subnet. Refer to any third party security program's Help or user forums for how to properly configure its firewall. Do not run more than one firewall. DO NOT TURN OFF FIREWALLS; CONFIGURE THEM CORRECTLY.

B. For ease of organization, put all computers in the same Workgroup. This is done from the System applet in Control Panel, Computer Name tab.

C. Create matching user accounts and passwords on all machines. You do not need to be logged into the same account on all machines and the passwords assigned to each user account can be different; the accounts/passwords just need to exist and match on all machines. DO NOT NEGLECT TO CREATE PASSWORDS, EVEN IF ONLY SIMPLE ONES . If you wish a machine to boot directly to the Desktop (into one particular user's account) for convenience, you can do this:

Start>Search box>type: netplwiz [enter]
Click on Continue (or supply an administrator's password) when prompted by UAC

Uncheck the option "Users must enter a user name and password to use this computer". Select a user account to automatically log on by clicking on the desired account to highlight it and then hit OK. Enter the correct password for that user account (if there is one) when prompted. Leave it blank if there is no password (null).

XP - Configure Windows to Automatically Login (MVP Ramesh) - http://windowsxp.mvps.org/Autologon.htm

D. If one or more of the computers on your network is XP Pro or Media Center, turn off Simple File Sharing (Folder Options>View tab).

E. Create shares as desired. In Windows 7 I usually share out the user's Desktop and the Public directory.

MS-MVP - Elephant Boy Computers - Don't Panic!
Elephant Boy Computers - Don't Panic!

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated June 6, 2018 Views 4,789 Applies to: