Windows Media Center doesn't run when on a Remote Desktop session

I have just setup Remote Desktop on my local server and connected to it from my laptop... whew that was a task in itself!

 

Server - Windows 7 Ultimate w/Media Center installed

Laptop - Windows 8 Pro w/Media Center installed

 

I am able to run Windows Media PLAYER on the remote desktop and it seems to work fine after I added the libraries to it.

 

BUT

 

When I run Windows Media CENTER I get a message that "Windows Media Center has stopped working... Windows is checking for a solution to the problem."  The message goes away and that's that.

 

Anyone got any thoughts on how I can get the WMC to run on the remote desktop?

 

Question Info


Last updated July 20, 2019 Views 1,202 Applies to:
Answer
Answer

Not quite sure why this would be considered an "ITPro" issue.

 

It is probably debateable that MS really intended for MC to be used via RDP, I am not sure that they thought the feature was used very much at all judging by what they did in Windows 8

 

However there are two possibilities over the cause of this. An update to the RDP client may be the culprit but it is not always a good idea to block any update.

 

Alternatively the following reg key

 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\Rdp-Tcp

 

needs the Users group added to have read access included in its permissions. Alternatively use the Run As Administrator option when starting Media Centre.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.