Windows 7 won't see XP computers on home network

Hi,

I have the following problem/set up
(a) home network with 4 PCs running XP SP3, 1 running Windows 2000 and 1 (new) running Windows 7
(b) all the computers can see each other and access each other's files EXCEPT the Windows 7 PC
(c) all computers are on the same Workgroup (incl. the Windows 7 PC)
(d) all computers have firewall s/w (mixture of Panda, Norton and Trend Micro) - switching on/off makes no difference on the Windows 7 PC
(e) all computers have the same user account with the same password
(f) for all computers the IP address is fixed (e.g. 192.168.0.101 to 192.168.0.105) and the DNS is set to the same 192.168.0.1

Set-up on the Windows 7 PC:
1. in the Network and Sharing Center, the active network is Home network
2. but Access type is 'Internet' (no 'Local access') and changing the network type to Work or Public makes no difference
3. in Advanced Settings, Network Discovery, File and Printer Sharing, Public Folder sharing and Password Protected Sharing are all ON
4.  Norton Internet Security 2009 is running and shows all the computers on the network under Network Security Map
5.  Using a CMD window I can ping the XP computers with no problem.

Any suggestions would be much appreciated.

 

Question Info


Last updated July 14, 2018 Views 21,736 Applies to:
Answer
I have finally solved this problem. On the windows 7 pc, set the network to "work group" , not home group. In the network page, under sharing options, make sure network discovery is on, as well as sharing and printer oprions. On the same screen, turn off password protected sharing. At ther bottom of the page, click on the "public" link, do the same on theis page as on the network page. Because Password Protected Sharing is turned off, the security permissions have to be changed on the folder(s) to allow Everyone access. Right-click the shared folder > Properties > Security Tab > Edit > Add and type “Everyone” (not the quotes) into the box and select OK. Tick the boxes next to the permissions you want to allow (e.g. Read or Write, etc.) then Apply > OK.  Some messages may appear: “An error occurred while applying…” This is not unusual and can be ignored by clicking Continue. Next, if you have any antivirus software on any computer, such as Norton, Kaspersky, McAfee, etc., turn OFF the firewalls, leaving only the Windows firewall on. In order for the XP pc's to be able to see any files on the windows 7 pc, the files must be in a "public" folder. Using the SNAP feature (a wonderful thing!) open the library on both windows. On the lefthand column, click on the arrow by Pictures, the dropdown will show the public folder. Click and drag the folders you want to be public from one side to the other one with the public folder open.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.