Windows 7 - Why is the Network Adapter Priority ignored while connected to Domain on a lower priority NIC?

I have two NICs installed on my laptop.  I wanted to test and see how Windows 7 Ultimate handled the priority of NICs so I connected one to a Internet Small Office Router (NIC B) and the other in on my Domain (NIC A). 
First off, it was a pain to find the network adapter priority.  After some searching and Google fun I found it.  Sadly, the Search bar didn't help.
Control Panel -> Network and Internet -> View network status and tasks -> Change adapter settings -> Hold down 'alt' to bring up the "File" menu -> Select "Advanced" -> Select "Advanced Settings" from the dropdown menu -> Adjust your adapter priorities in the "Advanced Settings" window under the "Adapters and Bindings" tab.

With "NIC B" set as highest priority I tried to browse the internet.  It was unable to browse.  So then I disabled "NIC A" (the domain NIC) and I can browse the internet.  In Windows XP it handled this a lot better. 

Enable "NIC A" and then verify "NIC B" is highest priority.  Then try to tracert to www.google.com.  It brings up my domain router as the first hop.  It seems to completely be ignoring "NIC B" unless I disable "NIC A" altogether.

 

Question Info


Last updated November 2, 2018 Views 57,068 Applies to:
Answer
In case someone else comes here looking for the answer to this like I did, I thought I'd post the real solution to this issue.  Lots of web pages say to change the priority of the network connections by going to <Network and Sharing><Change Adapter Settings><Advanced Menu><Advanced Settings> and changing the order there to what you like.  Don't bother with that setting.

That doesn't work. It apparently has no effect on the use of the connections.

What Windows actually uses is the metric value for the network connections.  The lowest metric value is tried first.  In my case, I have a lousy broadband connection at home but I can tether wirelessly to my phone for occasional good bandwidth.  So I want to always use the wireless if connected and ignore the wired connection but still get to the printers and other things on my wired network at the same time.  So I want to keep them both on, and not have to disable the wired connection when I use my phone.

To fix this for real, go to <Network and Sharing><Change Adapter Settings>  and right click your wired and wireless adapters one at a time to change the properties.  Select IPv4, click <Properties> then click <Advanced>.  For each one, clear the "Automatic metric" check box and assign the metric value manually.  I set the wireless to 1 and the wired to 2, which gave me the behavior I wanted.

The automatic metrics are set by Windows based on the connection speed and a wired connection is usually faster than a wireless one. 


52 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.