Windows 7 unable to map drive to DNS 323 NAS Device.

Ok I am just about going out of my mind with this one. I have a DNS 323 NAS device connected directly to my laptop with static IP's and a crossover cable (removed it from my network for troubleshooting simplicity). I am running Windows 7 Pro. I can access the web interface of this device, ping it and Windows 7 sees it in the network sharing screen (taked me to the web interface when I click on it). I have tried to map a drive to it using map drive using the server name and Ip and I get the same result. It just says it can't connect. I have removed all fireewall and virus programs. I have reset the NAS to factory defaults and latest firmware.  I have tried safe mode with networking and nothing. I can however launch XP mode and that works fine for mapping the drive.

When I plug this NAS in using the above method to another box running XP pro and  yet another runnning Windows 7 Pro they can map the drives no problem.  So I think I have narrowed it down to something with my Windows 7. It was working when I first installed 7, but I havn't accessed this NAS in a while, so not sure when it stopped.

Can someone help, this is driving me crazy!!!!!

 

Question Info


Last updated December 9, 2019 Views 15,881 Applies to:
Answer
Answer

I cannot take credit for this answer - I saw it in another forum: Uninstall Windows Live Login Assistant ... it worked for me! I was unable to map drives from Win7, whereas I could do it fine with XP.

 

I have no idea why this works.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.