Windows 7 refuses DHCP addresses if they were previously assigned to another adapter, even if that is disconnected.

Windows 7 Professional 64-bit on a laptop here.

I have 2 adapters - LAN and WLAN.  If LAN only is enabled, then it'll get an IP address just fine.  If I disable LAN and enable WLAN, that will also get an IP address (the same one; the DHCP server is configured to give it to both MAC addresses).  LAN hardware identifies as "Broadcom NetLink (TM) Gigabit Ethernet", WLAN as "Intel(R) WiFi Link 5100 AGN".

However, if I unplug the LAN without enabling it and enable the LAN, the WLAN is not accepting the IP address that it is offered (I can see the DHCP server continually offering the correct address; Windows 7 does not accept it).  If I then disable the disconnected LAN connection the WLAN connection will finally accept the address it is being offered.

How can I change this behaviour so that the WLAN will accept an address as soon as it is offered?  When moving a laptop away from a desk I don't want to fiddle with"Control Panel\All Control Panel Items\Network Connections" every time.

If I tell the DHCP server to assign a different address to the LAN and WLAN MAC addresses the problem doesn't occur, although that's not a practical workaround since I can no longer predict what IP address I'll be assigned at any one time.

 

 

Question Info


Last updated June 1, 2019 Views 13,617 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I would think that would be an issue with the router firmware not Windows 7, ie. the lease time of the IP address. Have you tried a simple release/renew command? Go to Start | Run and type cmd /k ipconfig /? for the command syntax. Why do you want to assign the same IP address to both adapters, ie. wired and wireless, on a laptop to start with?
MS-MVP Windows Desktop Experience, "When all else fails, read the instructions"
MS-MVP Windows Expert - Consumer
"When all else fails read the instructions"

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks - yes, I've tried various release and renew options, to no avail (although of course having to do a manual "ipconfig/<something>" when unplugging a network cable would of course be less functional than e.g. Windows XP). It's not a router issue - other laptops running Windows XP, various versions of Linux (and also one other Windows 7 machine) are set up in exactly this way without problems. I can see the DHCP server offering the address - for some reason it isn't accepting it. What would be useful would be a way of filtering DHCP client messages - there's some info in the system event log but frankly nothing particularly useful. The fact that another Windows 7 machine doesn't seem to have the same problem (which I've just discovered) suggests that it might be related to the LAN driver comfiguration or hardware - that's where I'll look next. However, while looking into this I did notice quite a few posts here and elsewhere saying "Windows 7 / Vista doesn't accept DHCP addresses" - I wonder if any of those are related?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi

You cannot configure the DHCP server to provide the same IP to two MAC numbers that is confusing to the device.

Assign a unique IP to each network card with its own MAC.

Configure the Metrics of the wire TCP/IP to a lower number than the Wireless.

When the Wire is plugged in, it will prefer the wire connection, when you unplug the wire the Wireless will kick in automatically.

Here how, http://www.ezlan.net/metrics.html

 


Jack-MVP Windows Networking. WWW.EZLAN.NET
Jack MVP, Microsoft Windows Desktop Experience-Networking.

www.EZLAN.net

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same problen and:

1. It is not a problem of dhcp server since the ip i still offered to a client

2. Dhcp can be configured to map the same ip for multiple mac address! and it is sensible and useful

3. Windows does not clear the ip information for the interface that was disconnected even if command ipconfig /releas is issued.

4. Windows clears the ip information if the interface that was disconnected is disabled nad folowed by enabled

5. Windows clears the ip information if the command ipconfig /release is issued before media is diconnected

SO!

How to force Windows to clear IP information for disconnected media and folowed by accept the same IP for new interface obtained from dhcp?

I have not found any register key value to change thi odd behaviour.

I am not sure if it is a  driver specific.

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Dhcp can be configured to map the same ip for multiple mac address! and it is sensible and useful

Hi

A lot of issues like this are counting on Network devices that are really conforming rigorously to standards.

Entry level Routers used by 99% of the people that post here cost x10 times less than Pro Network Devices.

Beside poor QA, the devices do not adhere rigorously to standards.

The good part of it is that the price allow people to enjoy affordable home networking.

However whenever end-users start to deviate from simple and start to manipulate (or over task) their Network devices the low price raise its “ugly face”.

 


Jack-MVP Windows Networking. WWW.EZLAN.NET
Jack MVP, Microsoft Windows Desktop Experience-Networking.

www.EZLAN.net

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The dhcp server in my case is http://packages.debian.org/lenny/dhcp3-server .  Perhaps you could eplain in what way it does "not adhere rigorously to standards."?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The dhcp server in my case is http://packages.debian.org/lenny/dhcp3-server .  Perhaps you could eplain in what way it does "not adhere rigorously to standards."?

Hi

 You did not mentioned before the make of your Server.

My answer thus was a general one. I am Not familiar with you DHCP server so i can not give a specific answer.

 

 


Jack-MVP Windows Networking. WWW.EZLAN.NET
Jack MVP, Microsoft Windows Desktop Experience-Networking.

www.EZLAN.net

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The problem shows that Microsoft's programmers think too much and not brilliant enough.

Consider the following situation:

1. You have the work network 192.168.1.0/255.255.255.0 and home network also 192.168.1.0/255.255.255.0

2. You have ordinary laptop with two interfaces wire and wireless,

3. At work ip 192.168.1.5 is given for wire and you use this interface

4. At home ip 192.168.1.5 is given for wireless and you use this interface

Notice that no dhcp standard is violent!

But the problem exists!

If you hibernate laptop at work and wake up at home laptop won't connect to router.

 

Of cours such scenario is ridiculous but the essential problem is that:

! I WANT MY LAPTOP TO HAVE ONE FIXED IP REGARDLESS OF WHICH NETWORK INTERFACE IS CONNECTED TO MY ROUTER !

Is my whish ridiculous or not?

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Having the exact same issue. Using dnsmasq as my dhcp server. An excerpt from dnsmasq man page:

  • As a special case, it is possible to include more than one hardware address. eg:--dhcp-host=11:22:33:44:55:66,12:34:56:78:90:12,192.168.0.2 This allows an IP address to be associated with multiple hardware addresses, and gives dnsmasq permission to abandon a DHCP lease to one of the hardware addresses when another one asks for a lease. Beware that this is a dangerous thing to do, it will only work reliably if only one of the hardware addresses is active at any time and there is no way for dnsmasq to enforce this. It is, for instance, useful to allocate a stable IP address to a laptop which has both wired and wireless interfaces.

Blaming dhcp servers and users for using this convenient option is nonsense. Windows needs to let go of an IP address once the wire has been disconnected! Actually, I even have problems releasing/renewing my interfaces when faced with this situation. Disabling/Enabling the Network Adapter seems the only way. Another way is to do an ipconfig /release before pulling out the wire, but it's painful... Sigh.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

And still no ideas ??

Knowing Microsoft there is probably undocumented register key to change this strange behaviour.

Note that Winodws XP does not refuse the "new" but the same IP.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.