Question

Q: Windows 7 problem - Network adapter suddenly stopped working.

I upgraded a PC from XP to Windows 7 about a month ago. It was working fine until this morning. Suddenly there is no network - local or internet. I have tried uninstalling the network adapter from Device Manager (onboard NVIDIA chipset) and updating the driver several times to no avail. It's a fairly new motherboard (about a year old) - Intel Core 2 Quad processor with plenty of RAM.

I know it is not the internet connection or the router, because my other Win 7 PC still has access.

When I run the troubleshooter, Windows tells me that there is a problem with the network adapter. I tried removing a working Netgear PCI WiFi adapter from the other PC and installing it in this one. It installs fine and finds the driver, but the wireless adapter will not work either. The troubleshooter says that the WiFi adapter also has a problem.

To verify that the wired Ethernet adapter works, I rebooted the PC in windows XP (I still have the old HDD with the XP OS on it). The NIC in this PC works fine in Windows XP (accesses the LAN and internet with no problems).

At this point, it seems very likely that it is a software issue in Windows 7. Darn! I was really enjoying Windows 7 till this happened.

Please help. I don't want to go to all the trouble of re-installing Windows 7.

Thanks

Answer

A:

Hi,
Welcome to Microsoft answers.

 I would suggest you to check the below suggestions and see if it helps:

 Type cmd in the search bar and press enter. At the command line, type ping 127.0.0.1 and pres enter. You should get a response time back as a result. Something like this.
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128

If you do not, close the window and type device manager in the search bar and look under network adapters. See if you have a wireless device there and make sure there are not exclamation marks next to it.

If you have exclamation marks or any errors, reinstall the driver.

 I would suggest you to follow the below steps and check if it helps to resolve the issue:

 I would suggest you to check in Safe Mode with networking and check if it helps:
1.     Restart your computer if it is powered on.
2.     Tap the F8 key after your computer initially powers on.
3.     Once you see the Advanced Boot Options menu you can stop tapping.
4.     Use the up/down arrow keys to highlight your selection.
5.     Select Safe Mode with Networking and press Enter.
6.     You should see drivers loading, and then Please wait.
7.     You should then be at the Welcome Screen.
8.     Logon to your computer using an account with Administrator privileges.

To uninstall from device manager,

1. Open Device Manager by clicking the Start button, clicking Control Panel, clicking System and Maintenance, and then clicking Device Manager.‌
2.  If you are prompted for an administrator password or confirmation, type the password or provide confirmation.
3. On the Device Manager window, right click on the Device and select Uninstall.

Check the status of the Network adapter in the device manager. 

I also suggest you to change the security firewall settings to different levels and try to connect and check if it works.

 You can also run Network troubleshooter and check if it helps, here is the link:
http://windows.microsoft.com/en-US/windows7/Open-networking-troubleshooters

 Please respond back for the status on the issue and let us know if you have any issues.

  Thanks and Regards,
Azam – Microsoft Support.

Did this solve your problem?

Sorry this didn't help.

60 people were helped by this reply



 
Question Info

Views: 56,492 Last updated: July 20, 2018 Applies to: